← Back to team overview

kernel-packages team mailing list archive

[Bug 1047531] Re: Ubuntu 12.04 (Precise) guests can't boot on Ubuntu 10.04 (Lucid) QEMU-KVM host


(lowered priority since there is a workaround - using the backports
kernel.  I don't believe this is a bug in qemu-kvm, since newer kernel
fixes it, but I'm not yet marking it invalid for qemu-kvm since it's
possible qemu-kvm coudl work around it somehow if it did the right

** Changed in: qemu-kvm (Ubuntu)
   Importance: High => Medium

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Ubuntu 12.04 (Precise) guests can't boot on Ubuntu 10.04 (Lucid) QEMU-
  KVM host

Status in “linux” package in Ubuntu:
Status in “qemu-kvm” package in Ubuntu:

Bug description:
  For a couple of days I'm trying (on and off) to launch Ubuntu 12.04
  guest (32-bit) on my 10.04 KVM host (AMD CPU in 32-bit mode with PAE
  enabled, stock server kernel). I have tried it with different images
  (built with VMBuilder, downloaded from cloud-images.ubuntu.com or even
  the installation ISO images of different flavors). They all hang on
  boot, either after saying "Starting up ..." or just with a black
  screen. Kernel options have no effect, it seems the hang happens in
  GRUB, before kernel is launched. I have tried enabling debug in grub
  and the last lines I see about loading initrd, malloc and several
  reallocator.c traces, then hang.

  A simple steps to reproduce:

  # wget http://uec-images.ubuntu.com/releases/precise/release-20120822/ubuntu-12.04-server-cloudimg-i386-disk1.img
  # qemu-img convert -O qcow2 ubuntu-12.04-server-cloudimg-i386-disk1.img moa.qcow2
  # kvm -m 512 -smp 1 -drive file=./moa.qcow2 -vnc

  In attached vnc client this briefly displays GRUB prompt and hangs
  with black screen.

  The same happens without image conversion step, that is
  # kvm -m 512 -smp 1 -drive file=./ubuntu-12.04-server-cloudimg-i386-disk1.img -vnc

  At the same time, the host perfectly runs about 10 Lucid guests, so
  this should not be a host configuration problem.

To manage notifications about this bug go to: