← Back to team overview

kernel-packages team mailing list archive

[Bug 1076103] Re: [Asus Eee PC 1215B] Resume doesn't work after suspend


[Expired for linux (Ubuntu) because there has been no activity for 60

** Changed in: linux (Ubuntu)
       Status: Incomplete => Expired

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Asus Eee PC 1215B] Resume doesn't work after suspend

Status in “linux” package in Ubuntu:

Bug description:
  I had this bug with kubuntu 11.10 and it is still present after
  upgrade to 12.04. I have an Asus 1215b laptop with Amd C60 cpu.

  If I try to suspend the laptop, suspend seems to work at first, but then:
  1) most of the times, the attempt to resume it brings to a black screen as a result.
  2) After that, it is necessary to switch off the laptop by keeping the power button pressed.
  3) Trying to switch on the laptop again produces a black screen and no boot, unless I first remove the power cord and the battery, and try again after putting them back in place.
  4) Sometimes the first suspend attempt works correctly, but then, after a succesful resume, the second attempt reproduces the bug again.

  I tried the followings to see if it could help:
  1) Changed from radeon driver to ATI proprietary fglrx driver, same result.
  2) Installed the kernel 3.5.7 from http://kernel.ubuntu.com/~kernel-ppa/mainline, but I had problems with the fglrx ATI driver, and the first suspend and resume attempt immediatelly reproduced the bug

  Last, the bug has been present with all the kernel versions used with
  kubuntu 11.10 to current kernel version in Kubuntu

  uname -r: 3.2.0-32-generic

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-32-generic 3.2.0-32.51
  ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
  Uname: Linux 3.2.0-32-generic x86_64
  NonfreeKernelModules: fglrx
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu14
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 1: SB [HDA ATI SB], device 0: ALC269VB Analog [ALC269VB Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC1:  teresa     1891 F.... pulseaudio
   /dev/snd/controlC0:  teresa     1891 F.... pulseaudio
   Card hw:0 'Generic'/'HD-Audio Generic at 0xfeb44000 irq 40'
     Mixer name	: 'ATI R6xx HDMI'
     Components	: 'HDA:1002aa01,00aa0100,00100200'
     Controls      : 6
     Simple ctrls  : 1
   Simple mixer control 'IEC958',0
     Capabilities: pswitch pswitch-joined penum
     Playback channels: Mono
     Mono: Playback [on]
   Card hw:1 'SB'/'HDA ATI SB at 0xfeb40000 irq 16'
     Mixer name	: 'Realtek ALC269VB'
     Components	: 'HDA:10ec0269,1043841c,00100100'
     Controls      : 17
     Simple ctrls  : 10
  Date: Wed Nov  7 20:15:02 2012
  HibernationDevice: RESUME=UUID=08d31149-e27a-4d9a-aede-604cb2dac29b
  InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  MachineType: ASUSTeK Computer INC. 1215B
  ProcKernelCmdLine: root=UUID=9541887a-c1e1-4987-af3f-81118bf5262d ro nomodeset
   linux-restricted-modules-3.2.0-32-generic N/A
   linux-backports-modules-3.2.0-32-generic  N/A
   linux-firmware                            1.79.1
  SourcePackage: linux
  UpgradeStatus: Upgraded to precise on 2012-04-29 (191 days ago)
  dmi.bios.date: 06/17/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0401
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: 1215B
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: x.xx
  dmi.chassis.asset.tag: 0x00000000
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK Computer INC.
  dmi.chassis.version: x.x
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0401:bd06/17/2011:svnASUSTeKComputerINC.:pn1215B:pvrx.x:rvnASUSTeKComputerINC.:rn1215B:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
  dmi.product.name: 1215B
  dmi.product.version: x.x
  dmi.sys.vendor: ASUSTeK Computer INC.

To manage notifications about this bug go to: