← Back to team overview

kernel-packages team mailing list archive

[Bug 1272777] Re: Elantech touchpads not fully supported for some Gigabyte laptops


ApportVersion: 2.13.1-0ubuntu2
Architecture: amd64
 /dev/snd/controlC0:  nico       1652 F.... pulseaudio
CurrentDesktop: LXDE
DistroRelease: Ubuntu 14.04
InstallationDate: Installed on 2013-06-12 (227 days ago)
InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
MachineType: GIGABYTE U2442
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-5-generic.efi.signed root=UUID=a75d50a4-b759-46bb-b0e6-0f82fb14d1ab ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
 linux-restricted-modules-3.13.0-5-generic N/A
 linux-backports-modules-3.13.0-5-generic  N/A
 linux-firmware                            1.122
 0: phy0: Wireless LAN
 	Soft blocked: no
 	Hard blocked: no
StagingDrivers: zram
Tags:  trusty staging
Uname: Linux 3.13.0-5-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-01-19 (6 days ago)
UserGroups: adm audio cdrom dialout fax fuse lp lpadmin netdev plugdev sambashare sudo video
dmi.bios.date: 10/26/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: U2442.F306
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: U2442
dmi.board.vendor: GIGABYTE
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrU2442.F306:bd10/26/2012:svnGIGABYTE:pnU2442:pvrTobefilledbyO.E.M.:rvnGIGABYTE:rnU2442:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: U2442
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: GIGABYTE

** Tags added: apport-collected staging trusty

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Elantech touchpads not fully supported for some Gigabyte laptops

Status in “linux” package in Ubuntu:

Bug description:
  This bug report is in addition to
  https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1166442 - the
  fixes suggested there (which work for others) have been tried but do
  not work for a small subset of laptops, particularly the Gigabyte
  U2442 series.

  Description of the situation for my Gigabyte U2442V most recently
  running 3.11.0-12-generic on Linux Mint.

  I tried the updated module mentioned in the above bug report (1166442). It compiles and it detects an Elantech trackpad of *indeterminate version*.  I get this in dmesg:
  [859697.496141] psmouse serio1: elantech: assuming hardware version 3 (with firmware version 0x450f01)
  [859697.526011] psmouse serio1: elantech: Synaptics capabilities query result 0x58, 0x17, 0x0c.
  [859697.765917] psmouse serio1: elantech: retrying ps2 command 0x0b (2).
  [859698.470556] psmouse serio1: elantech: retrying ps2 command 0x0b (1).

  I get no Synaptics driver functionality, and only basic touchpad
  behaviour (motion and tap-to-click for left click, no scroll or
  disabling the pad when typing, etc.).

  It seems I don't have a v9 or v10 trackpad, I've never been able to
  get a definitive indication of which version I have got.

  The only thing that has remedied this problem for me in the past was
  the one described in the original bug report (for elantech-v6 -
  intel/+bug/681904/comments/64)... but it no longer applies to newer

  With the 3.11.0-12-generic kernel, my Touchpad *is* detected, i.e. xinput shows:
    ↳ PS/2 Elantech Touchpad id=16 [slave pointer (2)]
  and dmesg shows:
   input: PS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input14

  There are no useful touchpads settings evident in the normal Cinnamon
  settings utility (gnome-control-center -> Mouse & Touchpads).  I see a
  touchpad settings option with the "gpointing-device-settings" app and
  I can turn on vertical and horizontal scrolling in the interface, but
  doing so does not in any way affect that actual touchpad behaviour.

  I've also tried installing the elantech-v7 module via dkms (see
  and it compiles, but it too fails to provide the desired

To manage notifications about this bug go to: