← Back to team overview

kernel-packages team mailing list archive

[Bug 880316] Re: Ubuntu installer can't setup network on Shuttle XS35GTV2


I updated my driver like suggested by Jabba56 in comment #11 and voila
it's fixed.

The strange thing in my situation was that I was able to connect using 1000mbit connection but not on a 100mbit connection.
Will say before the update an ethernet cable on a 1000mbit networks has worked and the same cable on a 100mbit didn't.

After the driver update this bug was fixed.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Ubuntu installer can't setup network on Shuttle XS35GTV2

Status in “linux” package in Ubuntu:

Bug description:
  I'm trying to install Ubuntu on a Shuttle XS35GTV2.

  The installer can't set up the network connection.
  I've tried Ubuntu 10.04 32 and 64 bit netinstall, minimal and server, Ubuntu 11.10 32 bit netinstall.
  The Debian Squeeze 64 bit netinstall installer has no problem.
  (I've now installed openELEC which has no problems too)

  I was able to install Ubuntu 10.04 64 bit server but only without network connection. I then could load the jme module:
  # modprobe jme
  # depmod -a
  without errors.

  But I can't get eth0 running.

  The output of lspci is:
  02:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller (rev 03)
  03:00.0 Network controller: Realtek Semiconductor C., Ltd Device 8176 (rev 01)

  # lshw -C network
    *-network DISABLED
         description: Ethernet interface
         product: JMC250 PCI Express Gigabit Ethernet Controller
         vendor: JMicron Technology Corp.
         physical id: 0.5
         bus info: pci@0000:02:00.5
         logical name: eth0
         version: 03
         serial: 80:ee:73:1f:ef:df
         size: 10MB/s
         capacity: 1GB/s
         width: 32 bits
         clock: 33MHz
         capabilities: pm pciexpress msix msi bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
         configuration: autonegotiation=off broadcast=yes driver=jme driverversion=1.0.5 duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
         resources: irq:17 memory:feaf4000-feaf7fff ioport:dc00(size=128) ioport:d800(size=256)
    *-network UNCLAIMED
         description: Network controller
         product: Realtek Semiconductor Co., Ltd.
         vendor: Realtek Semiconductor Co., Ltd.
         physical id: 0
         bus info: pci@0000:03:00.0
         version: 01
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress bus_master cap_list
         configuration: latency=0
         resources: ioport:e800(size=256) memory:febfc000-febfffff

  I've posted my problem at the Ubuntu users mailing list:

  Edit: Unfortunately I couldn't reassign it as it has nothing to do
  with gnome-nettools (see post #1).

To manage notifications about this bug go to: