← Back to team overview

kernel-packages team mailing list archive

[Bug 1283531] Missing required logs.


This bug is missing log files that will aid in diagnosing the problem.
>From a terminal window please run:

apport-collect 1283531

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

** Tags added: quantal

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Multiple NICs no longer work following Ubuntu update

Status in “linux” package in Ubuntu:

Bug description:

  I updated my Ubuntu Server 12.04.4 LTS yesterday using `sudo apt-get
  dist-upgrade`, and now, my two-NIC setup, which worked before the
  update, doesn't work. Per the instructions located at
  http://askubuntu.com/questions/310355/networking-with-multiple-nics, I
  set up another route (a few weeks before the update yesterday) and it
  all worked great. Now, since the update, something has gone wrong and
  it doesn't work anymore. (I'm guessing something in the updated

  At any rate, here is the content of my `/etc/network/interfaces` file:


  # The loopback network interface
  auto lo
  iface lo inet loopback

  # The primary network interface
  auto eth1
  iface eth1 inet static
  #       dns-nameservers

  auto eth0
  iface eth0 inet static
  #       dns-nameservers

  post-up ip rule add from lookup 101
  post-up ip route add default via dev eth0 table 101
  post-down ip rule del from
  post-down ip route del default via table 101


  And here is the output of `ip route show`:

  default via dev eth1  metric 100 dev eth0  proto kernel  scope link  src dev eth1  proto kernel  scope link  src

  And the output of `ip route show table 101`:

  default via dev eth0

  Finally, here is the relevant part of the APT history log,

  Start-Date: 2014-02-21  14:44:55
  Commandline: apt-get dist-upgrade
  Install: linux-image-3.5.0-46-generic:amd64 (3.5.0-46.70~precise1), linux-headers-3.5.0-46-generic:amd64 (3.5.0-46.70~precise1, automatic), linux-headers-3.5.0-46:amd64 (3.5.0-46.70~precise1, automatic)
  Upgrade: perl:amd64 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), perl-base:amd64 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), python-apt:amd64 (0.8.3ubuntu7.1, 0.8.3ubuntu7.2), linux-image-generic-lts-quantal:amd64 (,, perl-modules:amd64 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), python-apt-common:amd64 (0.8.3ubuntu7.1, 0.8.3ubuntu7.2), linux-headers-generic-lts-quantal:amd64 (,, libcurl3:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), curl:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7), linux-generic-lts-quantal:amd64 (,, libperl5.14:amd64 (5.14.2-6ubuntu2.3, 5.14.2-6ubuntu2.4), libcurl3-gnutls:amd64 (7.22.0-3ubuntu4.6, 7.22.0-3ubuntu4.7)
  End-Date: 2014-02-21  14:45:56

  I didn't select a package because I'm not sure at what level this
  problem exists. If any of you have a better idea as to what the
  affected package might be, please let me know and I'll update (if I
  can) this ticket.

  Thank you so, SO much for your help with this!

  Best Regards,


To manage notifications about this bug go to: