← Back to team overview

kernel-packages team mailing list archive

[Bug 500999] Re: [i965gme] Freezes when attempting to switch to projector (or just detect them)


This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag 'verification-needed-
lucid' to 'verification-done-lucid'.

If verification is not done by 5 working days from today, this fix will
be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!

** Tags added: verification-needed-lucid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [i965gme] Freezes when attempting to switch to projector (or just
  detect them)

Status in “linux” package in Ubuntu:
  Fix Released
Status in “xserver-xorg-video-intel” package in Ubuntu:
Status in “linux” source package in Lucid:
  Fix Released
Status in “xserver-xorg-video-intel” source package in Lucid:

Bug description:
  Binary package hint: xorg

  Using up-to-date lucid as of 28th december, GME965/960 graphics.

  Attempting to plug-in external projector makes the computer freeze,
  even just opening the display dialog with a projector connected makes
  it freeze (no mouse movement).

  Booting up with projector plugged in results in many out of memory
  errors until eventually the kernel panics due to out of memory.

  The problem is fixed in linux 2.6.33-rc1. The commit that fixed it has
  been identified as:

  commit 9cf00977da092096c7a983276dad8b3002d23a99
  Author: Adam Jackson <ajax@xxxxxxxxxx>
  Date:   Thu Dec 3 17:44:36 2009 -0500

      drm/edid: Unify detailed block parsing between base and extension blocks
      Also fix an embarassing bug in standard timing subblock parsing that
      would result in an infinite loop.
      Signed-off-by: Adam Jackson <ajax@xxxxxxxxxx>
      Signed-off-by: Dave Airlie <airlied@xxxxxxxxxx>

  ProblemType: Bug
  Architecture: amd64
  Date: Mon Dec 28 17:51:47 2009
  DistroRelease: Ubuntu 10.04
  InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20091222.1)
  MachineType: Hewlett-Packard Compaq 510
  Package: xorg 1:7.5~3ubuntu4
  ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-9-generic root=UUID=8be2e4e2-547f-4a57-8f98-4f3169fbea42 ro quiet splash
  ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
   xserver-xorg 1:7.5~3ubuntu4
   libgl1-mesa-glx 7.6.1~rc3-1ubuntu1
   libdrm2 2.4.14-1ubuntu2
   xserver-xorg-video-intel 2:2.9.1-1ubuntu1
   xserver-xorg-video-ati 1:6.12.99+git20091125.0061c4db-0ubuntu1
  SourcePackage: xorg
  Symptom: display
  Tags:  freeze lucid
  Title: Xorg freeze
  Uname: Linux 2.6.32-9-generic x86_64
  XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
  dmi.bios.date: 09/24/2009
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: 68PVU Ver. F.08
  dmi.board.name: 308A
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: KBC Version 26.08
  dmi.chassis.asset.tag: CNU9457YHN
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: dmi:bvnHewlett-Packard:bvr68PVUVer.F.08:bd09/24/2009:svnHewlett-Packard:pnCompaq510:pvrF.08:rvnHewlett-Packard:rn308A:rvrKBCVersion26.08:cvnHewlett-Packard:ct10:cvr:
  dmi.product.name: Compaq 510
  dmi.product.version: F.08
  dmi.sys.vendor: Hewlett-Packard
  fglrx: Not loaded
  glxinfo: Error: [Errno 2] No such file or directory
   distro:             Ubuntu
   architecture:       x86_64kernel:             2.6.32-9-generic

To manage notifications about this bug go to: