← Back to team overview

kernel-packages team mailing list archive

[Bug 1083984] Re: 10de:0def [Lenovo Thinkpad T530] With discrete graphics brightness control doesn't work


** Also affects: linux
   Importance: Undecided
       Status: New

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  10de:0def [Lenovo Thinkpad T530] With discrete graphics brightness
  control doesn't work

Status in The Linux Kernel:
Status in “linux” package in Ubuntu:

Bug description:
  This laptop has Optimus. Following instructions on https://wiki.kubuntu.org/Kernel/Debugging/Backlight I have tried in /etc/default/grub kernel parameters:
  acpi_backlight=vendor, thinkpad-acpi.brightness_enable=1.

  I have tried /usr/share/X11/xorg.conf.d/10-brightness-control.conf:
  Option "RegistryDwords" "EnableBrightnessControl=1"

  I have tried editing /sys/class/backlight/acpi_video0/brightness with

  None of these have enabled brightness control.

  WORKAROUND: If I boot with integrated graphics instead of Nvidia, it
  works fine.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: linux-image-3.5.0-18-generic 3.5.0-18.29
  ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
  Uname: Linux 3.5.0-18-generic x86_64
  ApportVersion: 2.6.1-0ubuntu6
  Architecture: amd64
   /dev/snd/controlC1:  mwhite     2138 F.... pulseaudio
   /dev/snd/controlC0:  mwhite     2138 F.... pulseaudio
  Date: Tue Nov 27 23:39:07 2012
  HibernationDevice: RESUME=UUID=c574cd15-a9b9-4064-b22e-62b5bf4ce531
  InstallationDate: Installed on 2012-11-27 (0 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
  MachineType: LENOVO 2359CTO
  MarkForUpload: True
   PATH=(custom, no user)
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-18-generic.efi.signed root=UUID=fdfd5708-06eb-454a-a3c7-bdd98054c811 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.5.0-18-generic N/A
   linux-backports-modules-3.5.0-18-generic  N/A
   linux-firmware                            1.95
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/13/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G4ET62WW (2.04 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 2359CTO
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 Pro DPK TPG
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvrG4ET62WW(2.04):bd09/13/2012:svnLENOVO:pn2359CTO:pvrThinkPadT530:rvnLENOVO:rn2359CTO:rvrWin8ProDPKTPG:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 2359CTO
  dmi.product.version: ThinkPad T530
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: