← Back to team overview

kernel-packages team mailing list archive

[Bug 1291660] Re: Intel ixgbe driver doesn't work at 10Gb speeds


See the attached eth*.log files attached above.

I ran ethtool, pings, and netperf on eth0 and eth1 in two different
configurations.   One configuration is with eth0 and eth1 directly
connected to 10 Gb  ixgbe adapters on another system.  These are labeled
ptp for point to point.   I ran the same tests again using the ethernet
switch that Jeff used when originally filing this bug. These are labeled

The data seems to indicate that the ethernet switch/adapter conbination
is not running at 10 gig. The point to point connections show better
throughput, but not great throughput for a 10 gig adapter.

Let me know if you have something specific in mind you'd like me to


You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Intel ixgbe driver doesn't work at 10Gb speeds

Status in “linux” package in Ubuntu:

Bug description:
  I have a fresh install of 12.04.4 on an IBM server with an Intel 10GbE
  card (actually I have seen this on TWO systems, one with a PCIe 10GbE
  card and one with a mezzanine add-in card that has the same chipset).

  12.04.4 ships with ixgbe version 3.13.10-k

  Initially, when the ethernet device comes up, it sets itself at 1Gb
  not 10Gb.  If you do an ethtool on one of the devices, they clearly
  show supported speeds of 100, 1000 and 10000Mb/s as well as advertised
  speeds of that nature.

  Also, ethtool clearly shows the current speed at 1000 .

  now, if you force the card to a speed of 10000 like so:

  sudo ethtool -s eth0 speed 10000 duplex full

  Ethtool will NOW show "Unknown!" for speed and duplex settings, and
  will drop the link.

  The link will restore, as will the rest of the output, if you put the
  card back to the 1000Mb/s speed.

  Thus, the ixgbe driver seems to be broken.

  I tried to use apport to file this bug, however apport told me that
  the linux and linux-image-generic packages are NOT official Ubuntu
  packages, and refused to create the report for me.

  Thus, I gathered what i could via sosreport and some other means,
  which I am attaching below.

  This will gate any certification that uses the Intel 10Gb NICs (seen
  onboard at least a couple server systems now).

To manage notifications about this bug go to: