← Back to team overview

kernel-packages team mailing list archive

[Bug 1276705] Re: Kernel 3.13 fail to boot with LSI SAS1068E (Dell SAS 6/iR)


(a) Linux kernel guys think that a hardcoded timeout is a systemd bug.


(b) The systemd guys think that kernel module loading takes more than
    30 seconds is a kernel module's bug. But Linux kernel guys won't
    be able to fix it immediately. Also, solution by updating firmware
    won't be acceptable because there will be users who can't update
    firmware for some reason.


    The systemd guys suggest that adding OPTIONS+="event_timeout=120"
    to udev rules might help, but I don't think it will help.


(c) The LVM guys added OPTIONS+="event_timeout=180" before
    commit 786235ee was merged into Linux kernel.


(d) I tried to rebuild systemd package with longer timeout but I was
    unable to build it without build failures. Therefore, I opened a
    bug report in order to ask for systemd package with longer
    timeout, but no response so far.


Well, it is unlikely that this situation is solved within 7 days.
I think that applying the patch in comment #48 as a
"[trusty] UBUNTU: SAUCE:" patch is the safest choice for 14.04 LTS

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Kernel 3.13 fail to boot with LSI SAS1068E (Dell SAS 6/iR)

Status in “linux” package in Ubuntu:
Status in “linux” source package in Trusty:

Bug description:
  We have recently upgraded an Dell R300 server to Trusty (was running
  fine in precise), and after upgrade it fail to boot.

  It is an issue with the SAS controller during the initilisation. It
  fail to detect the disk, we have the following error in console log:

  [   36.539955] scsi4: error handler thread failed to spawn, error = -12
  [   36.552694] mptsas: ioc0: WARNING - Unable to register controller with SCSI subsystem

  After this error, initramfs drop to a shell complaining that rootfs is
  not found. No disk is seen at all (cat /proc/partition only show sr0 -
  cdrom drive).

  We have this issue with two different server (both R300, both Dell SAS
  6/iR controller and same hardware).

  We don't have this issue with another Dell server (R310, Dell PERC

  We also tester with old kernel (generic, 3.2.0-58.88), it is working.

  Those server need a greater rootdelay (probably #579572), so we have
  rootdelay=45. If we remove rootdelay=45, then disk are correctly
  recognized ! (but few second too late, initramfs dropped to a shell.
  Pressing control-D resume normal boot)

  So the issue is that with the (mandatory) rootdelay greater that 30
  (default value I think), the disk are not detected due to the error
  shown above. This is a regression since those server worked in precise
  (and work with precise old kernel).

  System information

  * Dell R300 with Dell SAS 6/iR controller
  * Ubuntu Trusty Tahr (14.04)
  * Running arch: x86_64
  * Kernel version: 3.13.0-7-generic  (dpkg version : 3.13.0-7.25)
  * Kernel command line: BOOT_IMAGE=/vmlinuz-3.13.0-7-generic root=UUID=174e14b5-46fc-479b-9f94-05cb33c75ac9 ro rootdelay=45 console=tty0 console=ttyS1,57600 quiet
  * uname -a: Linux frtls-perf01 3.13.0-7-generic #25-Ubuntu SMP Tue Feb 4 10:19:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

  Attached files:

  * console output when error occure.
  * dmesg when system boot (no rootdelay, need to press control-d during initramfs boot)
  * lspci -vnn

  Tell me if you need more informations.

To manage notifications about this bug go to: