← Back to team overview

kernel-packages team mailing list archive

[Bug 1284085] Re: unable to boot after install on 2013 macbook air


I was using the OSX daily image from http://cdimage.ubuntu.com/daily-
live/current/ which did not present the options for efi or legacy.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  unable to boot after install on 2013 macbook air

Status in Release Notes for Ubuntu:
Status in “linux” package in Ubuntu:

Bug description:
  Booting and installing from a live usb for trusty does work. However,
  on restart the machine will not boot. It hangs at:


  Per apw in #ubuntu-kernel a test to add nr_cpus=1 does work to boot
  the machine.

  Note that wifi does not work at this point, but it does work in the
  live usb boot.

  For more information I did hit this with both the 3.13.0-8 and
  3.13.0-11 kernels as I tried to update.

  --- Original notes ---

  I'm attempting to install and run 14.04 trusty on a macbook air in a
  dual boot configuration. I have a Mac 64bit iso bootable usb device
  that I used to install on top of refind. The very first time I
  installed and setup it worked. I was in Ubuntu. I installed updates
  and some basic packages and when I rebooted it would no longer boot.

  I had gotten an updated kernel so I attempted to boot to the older -08
  kernel with no luck.

  I then attempted to reinstall. I figured I could avoid updates for the
  moment. I used the USB stick to do an install using the "Remove 14.04
  and install" option. When it was done, it would not boot just as

  I attempted to use the usb stick to rebuild grub using
  -ubuntu-live-cd with no luck.

  I've tried setting boot params in grub of nomodeset noapic. When I
  turn off the quiet mode I get the following screenshot where it hangs
  very early in the boot process around "Booting SMP configuration".

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-generic
  ProcVersionSignature: Ubuntu 3.13.0-8.28-generic 3.13.2
  Uname: Linux 3.13.0-8-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.13.2-0ubuntu4
  Architecture: amd64
   /dev/snd/controlC0:  ubuntu     3336 F.... pulseaudio
   /dev/snd/controlC1:  ubuntu     3336 F.... pulseaudio
  CasperVersion: 1.337
  CurrentDesktop: Unity
  CurrentDmesg: [  149.733266] ERROR @wl_cfg80211_get_tx_power : error (-1)
  Date: Mon Feb 24 07:08:09 2014
  LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64+mac (20140218)
  MachineType: Apple Inc. MacBookAir6,1
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
   linux-restricted-modules-3.13.0-8-generic N/A
   linux-backports-modules-3.13.0-8-generic  N/A
   linux-firmware                            1.124
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/12/2013
  dmi.bios.vendor: Apple Inc.
  dmi.bios.version: MBA61.88Z.0099.B07.1311121319
  dmi.board.asset.tag: Base Board Asset Tag#
  dmi.board.name: Mac-35C1E88140C3E6CF
  dmi.board.vendor: Apple Inc.
  dmi.board.version: MacBookAir6,1
  dmi.chassis.type: 10
  dmi.chassis.vendor: Apple Inc.
  dmi.chassis.version: Mac-35C1E88140C3E6CF
  dmi.modalias: dmi:bvnAppleInc.:bvrMBA61.88Z.0099.B07.1311121319:bd11/12/2013:svnAppleInc.:pnMacBookAir6,1:pvr1.0:rvnAppleInc.:rnMac-35C1E88140C3E6CF:rvrMacBookAir6,1:cvnAppleInc.:ct10:cvrMac-35C1E88140C3E6CF:
  dmi.product.name: MacBookAir6,1
  dmi.product.version: 1.0
  dmi.sys.vendor: Apple Inc.

To manage notifications about this bug go to:

Follow ups