← Back to team overview

kernel-packages team mailing list archive

[Bug 1296887] Re: Boot-time vlan network setup fails


Adding network-manager for review.

** Also affects: network-manager (Ubuntu)
   Importance: Undecided
       Status: New

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Boot-time vlan network setup fails

Status in “linux” package in Ubuntu:
Status in “network-manager” package in Ubuntu:

Bug description:
  It seems that vlan network setup fails at boot-time (but all works
  well after boot).

  This regression was introduced several (2-3) day ago.

  My /etc/network/interfaces
  $ cat /etc/network/interfaces
  # interfaces(5) file used by ifup(8) and ifdown(8)
  auto lo
  iface lo inet loopback

  auto eth0
  iface eth0 inet manual

  auto eth0.10
          iface eth0.10 inet dhcp

  auto eth0.20
          iface eth0.20 inet manual

  auto dsl-provider
  iface dsl-provider inet ppp
  pre-up /sbin/ifconfig eth0.20 up # line maintained by pppoeconf
  provider dsl-provider

  During boot I see "Waiting for network configuration...", after boot
  in ifconfig -a output I does NOT see eht0.10 and eth0.20 interfaces.

  But, if I run manually these commands AFTER boot
  ip link add link eth0 name eth0.10 type vlan id 10
  ip link add link eth0 name eth0.20 type vlan id 20
  pon dsl-provider

  all works perfectly.

  Also I tried to add "8021q" in /etc/modules but it did not help.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-19-generic 3.13.0-19.39
  ProcVersionSignature: Ubuntu 3.13.0-19.39-generic 3.13.6
  Uname: Linux 3.13.0-19-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.13.3-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC1:  dimanne    2784 F.... pulseaudio
   /dev/snd/controlC0:  dimanne    2784 F.... pulseaudio
  CurrentDesktop: KDE
  Date: Mon Mar 24 22:29:13 2014
  HibernationDevice: RESUME=UUID=e70873bf-d62f-4b4c-9f3c-823f35acb596
  InstallationDate: Installed on 2013-11-11 (133 days ago)
  InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  MachineType: System manufacturer System Product Name

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-19-generic root=UUID=b5fff7d9-81c4-43c5-94b6-902286582c80 ro quiet splash
   linux-restricted-modules-3.13.0-19-generic N/A
   linux-backports-modules-3.13.0-19-generic  N/A
   linux-firmware                             1.126

  SourcePackage: linux
  UpgradeStatus: Upgraded to trusty on 2014-02-21 (31 days ago)
  dmi.bios.date: 12/04/2008
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0202
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P6T
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0202:bd12/04/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP6T:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: