← Back to team overview

kernel-packages team mailing list archive

[Bug 1073391] Re: Incompatible with Marvell's SATA controllers 9123 with an SSD attached


** Tags removed: kernel-bug-exists-upstream
** Tags added: needs-upstream-testing

** Tags added: latest-bios-1601

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Incompatible with Marvell's SATA controllers 9123 with an SSD attached

Status in The Linux Kernel:
Status in “linux” package in Ubuntu:

Bug description:
  My controller is a marvell 9123 and the SSD is a Corsair Neutron
  240GB. The drive is brand new and because I thought it was a drive
  issue, I exchanged it against an other brand new one at my retailers.
  So the drive isn't the issue.

  First install went fine, but when I tried to install some packages
  using apt, the / file system got mounted read only. I tried to
  reinstall and got the same issue during installation.

  WORKAROUND: Disabled NCQ by adding "libata.force:noncq" to default
  kernel options of the installer.

  After the install, I added "libata.force=7:noncq" in /etc/default/grub like this:
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.force=7:noncq"

  and updated grub. I used "7:" because errors I saw occurred with ata7
  info in dmesg.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: ubiquity 2.12.16
  ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
  Uname: Linux 3.5.0-17-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.6.1-0ubuntu3
  Architecture: amd64
  CasperVersion: 1.328
  Date: Wed Oct 31 11:54:59 2012
  InstallCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash -- debian-installer/language=fr keyboard-configuration/layoutcode?=fr keyboard-configuration/variantcode?=oss
  LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
   PATH=(custom, no user)
  SourcePackage: grub-installer
  UpgradeStatus: No upgrade log present (probably fresh install)
  ApportVersion: 2.6.1-0ubuntu6
  Architecture: amd64
   /dev/snd/controlC1:  lox        2440 F.... pulseaudio
   /dev/snd/controlC0:  lox        2440 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  DistroRelease: Ubuntu 12.10
  HibernationDevice: RESUME=UUID=8889fa09-0b04-43a9-9c9d-abd62bd4c5b0
  InstallationDate: Installed on 2012-10-31 (0 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
   eth0      no wireless extensions.

   eth1      no wireless extensions.

   lo        no wireless extensions.
  MachineType: System manufacturer System Product Name
  MarkForUpload: True
  NonfreeKernelModules: nvidia
  Package: linux (not installed)

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=331096ea-7053-4995-bb8f-ae554c9dfabf ro quiet splash libata.force=7:noncq
  ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
   linux-restricted-modules-3.5.0-17-generic N/A
   linux-backports-modules-3.5.0-17-generic  N/A
   linux-firmware                            1.95

  Tags:  quantal running-unity
  Uname: Linux 3.5.0-17-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 09/28/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1601
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P7P55D-E DELUXE
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev 1.xx
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1601:bd09/28/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP7P55D-EDELUXE:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: