← Back to team overview

kernel-packages team mailing list archive

[Bug 153702] Re: Dell Inspiron 530 SATA drive not detected in IDE mode


** Changed in: somerville
       Status: New => Fix Released

** No longer affects: dell

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Dell Inspiron 530 SATA drive not detected in IDE mode

Status in module-init-tools:
Status in The Somerville Project:
  Fix Released
Status in Ubuntu:
Status in “linux” package in Ubuntu:
  Fix Released
Status in “linux-source-2.6.20” package in Ubuntu:
Status in “linux-source-2.6.22” package in Ubuntu:
  Won't Fix

Bug description:
  When configuring the SATA drive in IDE mode for the Dell Inspiron 530,
  the Gutsy 20071016.1 alternate installer doesn't detect the drive. So,
  it just fails with the error message: No root file system is defined.

  As mentionned in the syslog file, I tried booting with the irqpoll
  kernel parameter and the disk is still not detected.

  When configuring the SATA drive in RAID mode, the installation
  completes successfully.


  Current Dell workaround/customization for their Inspiron 530n :

  All Vostro 200 and Inspiron 530 are configured to use IDE instead of
  RAID by default. The Dell inspiron 530n includes a customized ubuntu
  that includes the Dell workaround for that issue, however any attempt
  to install a new ubuntu version without dell customization leads to
  computers that does not boot.

  Configuring the computer BIOS to use RAID instead of IDE is not a
  valuable solution since other operating systems like Windows won't
  boot without pre-installed SATA drivers unless BIOS is set back to
  IDE. IDE is the default "compatible" mode.

To manage notifications about this bug go to: