← Back to team overview

kernel-packages team mailing list archive

[Bug 1306712] Re: trusty on Intel NUC, xc5000 firmware load kills all USB


Tested with linux-

Fail case #1, bug still exists.  Output of lsusb -v core dumps when
enumerating the Hauppauge.  Perhaps it's a different issue.  My problem
was with all USB getting cut down when firmware loaded, and not
specifically with lsusb output..

Fail case #2, bug is corrected.  Application VLC can open /dev/video0
without cutting down the USB bus.

Marking as kernel-fixed-upstream.

Thank you for the quick response, grateful for the software and the

** Tags added: kernel-fixed-upstream

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  trusty on Intel NUC, xc5000 firmware load kills all USB

Status in “linux” package in Ubuntu:

Bug description:

  Intel NUC D54250WYK, kernel 3.13.0-23-generic x86_64, Trusty 14.10,
  package linux-firmware-nonfree 1.14ubuntu1

  Installed and updated trusty 2 days ago, also updated select libs
  yesterday trying to debug this issue.  Issue seems to be with firmware
  load and the usb subsystem.   When Hauppauge 950Q inserted to usb
  port, kernel sees it and reports what appears to be normal device
  recognition.  As soon as an application tries to access the Hauppauge
  device, there are problems.  Two examples can make it fail repeatedly.

  Fail case #1) 
  With Hauppauge inserted into usb port, as root, run lsusb -v
  it aborts when trying to ennumerate the Hauppauge device.

  Bus 002 Device 004: ID 2040:7200 Hauppauge 
  lsusb: gconv.c:74: __gconv: Assertion `outbuf != ((void *)0) && *outbuf != ((void *)0)' failed.
  Aborted (core dumped)

  This failure is non-harmful as the USB bus is still active and devices
  plugged into usb still function.

  Fail case #2) 
  With Hauppauge inserted, run VLC and choose to capture the video device.

  VLC runs, kernel reports the firmware load starting, and completing.
  As soon as firmware load completes, the USB bus and all devices
  plugged in there are cut down.  Unplug and replug USB devices has no
  effect, and additional usb plug events are not seen or reported by
  kernel.  Power off to recover.

  Tried debugging a little.  The linux-firmware-nonfree package provides
  dvb-fe-xc5000-1.6.114.fw, but the kernel asks to load a newer version,
  dvb-fe-xc5000c-  I got newer version from kernellabs.com
  and tried it.  Behavior is the same.

  Note- this device is known to work.  I have it working in ubuntu 11.10
  32bit, and in ubuntu 12.04 64bit.

  My kyb, mouse, and network card are all usb.  Do not have a wired
  ethernet connection to gain access (via ssh) after usb goes away..
  Will get that today but I don't know where to focus debug effort next.
  Gladly assist with additional debug.

  Attachment: output from ubuntu-bug linux with Hauppauge device mounted

To manage notifications about this bug go to: