← Back to team overview

kernel-packages team mailing list archive

[Bug 1306712] Re: trusty on Intel NUC, xc5000 firmware load kills all USB


Changed tag to kernel-bug-exists-upstream.  Additional testing provoked
the bug with all USB getting cut down.  As soon as data tries to flow
through the /dev/video0 -> usb connection, all USB stops.  Trying to
make wired ethernet connection next, perhaps to ssh in and still be able
to interrogate the box.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  trusty on Intel NUC, xc5000 firmware load kills all USB

Status in “linux” package in Ubuntu:

Bug description:

  Intel NUC D54250WYK, kernel 3.13.0-23-generic x86_64, Trusty 14.10,
  package linux-firmware-nonfree 1.14ubuntu1

  Installed and updated trusty 2 days ago, also updated select libs
  yesterday trying to debug this issue.  Issue seems to be with firmware
  load and the usb subsystem.   When Hauppauge 950Q inserted to usb
  port, kernel sees it and reports what appears to be normal device
  recognition.  As soon as an application tries to access the Hauppauge
  device, there are problems.  Two examples can make it fail repeatedly.

  Fail case #1) 
  With Hauppauge inserted into usb port, as root, run lsusb -v
  it aborts when trying to ennumerate the Hauppauge device.

  Bus 002 Device 004: ID 2040:7200 Hauppauge 
  lsusb: gconv.c:74: __gconv: Assertion `outbuf != ((void *)0) && *outbuf != ((void *)0)' failed.
  Aborted (core dumped)

  This failure is non-harmful as the USB bus is still active and devices
  plugged into usb still function.

  Fail case #2) 
  With Hauppauge inserted, run VLC and choose to capture the video device.

  VLC runs, kernel reports the firmware load starting, and completing.
  As soon as firmware load completes, the USB bus and all devices
  plugged in there are cut down.  Unplug and replug USB devices has no
  effect, and additional usb plug events are not seen or reported by
  kernel.  Power off to recover.

  Tried debugging a little.  The linux-firmware-nonfree package provides
  dvb-fe-xc5000-1.6.114.fw, but the kernel asks to load a newer version,
  dvb-fe-xc5000c-  I got newer version from kernellabs.com
  and tried it.  Behavior is the same.

  Note- this device is known to work.  I have it working in ubuntu 11.10
  32bit, and in ubuntu 12.04 64bit.

  My kyb, mouse, and network card are all usb.  Do not have a wired
  ethernet connection to gain access (via ssh) after usb goes away..
  Will get that today but I don't know where to focus debug effort next.
  Gladly assist with additional debug.

  Attachment: output from ubuntu-bug linux with Hauppauge device mounted
  ApportVersion: 2.14.1-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC2:  ajm        1479 F.... pulseaudio
   /dev/snd/controlC0:  ajm        1479 F.... pulseaudio
   /dev/snd/controlC1:  ajm        1479 F.... pulseaudio
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=3bd759c8-c3a6-478a-be0f-33979c43a52b
  InstallationDate: Installed on 2014-04-08 (2 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
   usb0      no wireless extensions.
   eth0      no wireless extensions.
   lo        no wireless extensions.
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-23-generic.efi.signed root=UUID=7600946f-7e95-4c85-8e0e-e056733d7a20 ro
  ProcVersionSignature: Ubuntu 3.13.0-23.45-generic 3.13.8
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.13.0-23-generic N/A
   linux-backports-modules-3.13.0-23-generic  N/A
   linux-firmware                             1.127
  Tags:  trusty
  Uname: Linux 3.13.0-23-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  _MarkForUpload: True
  dmi.bios.date: 03/03/2014
  dmi.bios.vendor: Intel Corp.
  dmi.bios.version: WYLPT10H.86A.0025.2014.0303.1008
  dmi.board.name: D54250WYK
  dmi.board.vendor: Intel Corporation
  dmi.board.version: H13922-303
  dmi.chassis.type: 3
  dmi.modalias: dmi:bvnIntelCorp.:bvrWYLPT10H.86A.0025.2014.0303.1008:bd03/03/2014:svn:pn:pvr:rvnIntelCorporation:rnD54250WYK:rvrH13922-303:cvn:ct3:cvr:

To manage notifications about this bug go to: