← Back to team overview

kernel-packages team mailing list archive

[Bug 1293569] Re: iwlwifi-7260-8.ucode causes network disconnections problems


I just tried by doing the following:
1. re-enabling 11n 
2. rebooting
3. disabling powersave
=> does not work

The PC looks connected to the AP but even google.com will time-out after some time (DNS_PROBE_FINISHED_NO_INTERNET).
Tried another website (http://test.com). Very slow connection. After a while, part of the website displays but lots of elements in the page don't show. A look at the console log shows that the browser got a net::ERR_NAME_RESOLUTION_FAILED for the elements in the page that do not show.

Let me know if I can help more.
The best I could do so far was installing mainline kernel 3.14.1 as well as the related firmware microcode from:

But even with this setup, I would still need to disable 11n to get wifi
working. So in the end, I wonder if installing the new kernel really had
any impact at all. I am not quite sure.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux-firmware in Ubuntu.

  iwlwifi-7260-8.ucode causes network disconnections problems

Status in “linux-firmware” package in Ubuntu:

Bug description:
  Running 14.04 (beta) with Kernel 3.13.0-17-generic

  I've encountered a strange and reproducible error with the
  iwlwifi-7260-8.ucode firmware.

  This laptop is a Dell XPS 12 (haswell). With the -8 firmware, it will
  connect fine to wifi for 30 or 40 mins at a time, then will start
  dropping connections repeatedly. Even modprobe -r unloading and
  reloading doesn't fix the issue, only a reboot will temporarily solve
  it for 40 mins at a time.

  Moreover, here is what's strange, is during these episodes of
  disconnection it seems to affect the actual router (2Wire), as the
  other devices in the house will also start to have issues (very slow
  connections, limited range,etc).  Once I reboot this laptop everything
  and all devices will return to normal.

  This issue has been fixed by me manually removing the -8 firware from
  /lib/firmware and letting the -7 firmware load instead. Since that has
  been done there has not been a single issue of this happening (now
  going on 4 days).

  let me know if there is any other information you would like me to

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-firmware 1.126
  ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
  Uname: Linux 3.13.0-17-generic x86_64
  ApportVersion: 2.13.3-0ubuntu1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Mon Mar 17 08:13:25 2014
  EcryptfsInUse: Yes
  InstallationDate: Installed on 2014-03-07 (9 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140307)
  PackageArchitecture: all
  SourcePackage: linux-firmware
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: