← Back to team overview

kernel-packages team mailing list archive

[Bug 568090] Re: ath5k should be loaded with nohwcrypt parameter


I can't believe this bug is already 4 years old. And it's only one file
and three words missing per default!

I encountered this bug on 26th April when I was installing a new Ubuntu
14.04 with a friend on his old laptop, since he wanted to move away from
XP. So this was one of his first experiences with linux, we nearly had
to give up installing, because of the broken network connection. And yet
after some searching it was only one (!) command which solved it for us:
echo "options ath5k nohwcrypt" | sudo tee -a /etc/modprobe.d/ath5k.conf

So could you please fix this and add /etc/modprobe.d/ath5k.conf with
"options ath5k nohwcrypt" per default!?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ath5k should be loaded with nohwcrypt parameter

Status in “linux” package in Ubuntu:

Bug description:
  After a lengthy thread, I was able to get to the bottom of my poor web
  browsing performance in Lucid Beta 2. Basically I kept gettng the
  "Waiting for <insert site here>..." status on whatever browser I used.
  Pages would load after a really long time, or sometimes not at all. My
  laptop uses the AR2413 chipset, which utilizes the ath5k wireless
  module. We were able to find that loading the module with the
  nohwcrypt parameter fixed my problem:

  sudo modprobe ath5k nohwcrypt

  psyke83 from the forums showed me how to automatically load the ath5k
  module with the said parameter on reboot.

  sudo sh -c "echo 'options ath5k nohwcrypt' >/etc/modprobe.d/custom-

  Hopefully this information can help others with similar hardware.
  Whether this should be a default for Lucid, I am not sure because I
  don't know if it affects everyone the same.  The thread is pasted
  below for full details of everything I tried to find the solution.


To manage notifications about this bug go to: