← Back to team overview

kernel-packages team mailing list archive

[Bug 1251580] Re: Display is heavily distorted after kernel upgrades


** Tags added: kernel-bug-exists-upstream-3.15-rc5 kernel-fixed-upstream

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Display is heavily distorted after kernel upgrades

Status in “linux” package in Ubuntu:

Bug description:
  The bug is present already at boot (even from a USB stick boot without
  installing) in all Ubuntu (and variants) relying on Linux kernels 3.10
  to 3.12 (-> still present in 3.13).

  Because it's so easy to boot via USB, I tried it on 7 computers (all
  of them Dell Optiplex 9010). The upshot is that old distros boot
  correctly, with working displays. The new 13.10 distros doesn't work
  (i.e. the display is distorted) on 3 computers.

  On my computer (which is one of the 3 malfunctioning), recovery mode
  also always display correctly.  Playing around with xrandr and the
  xorg.conf turoned out to be of no avail. I tried changing the Linux
  kernels (after indications from this Ubuntu forums thread:
  http://ubuntuforums.org/showthread.php?t=2186873  ). It turns out that
  kernels of version <= 3.9 are OK. Kernels  >= 3.10.19 are not OK. I'm
  willing to bisect in the 3.10.x range if deemed of interest.

  I kept the lshw, lspci, xdpyinfo, ddcprobe and Xorg.0.log of all these
  7 boots from USB stick. I put all those log files in a zip file
  availiable at  http://dfiles.eu/files/njfpo8b4k

  Here are the main differences I found in those files (except the
  Xorg.0.log which are not so handy to compare as the beginning of lines
  are always different).

  I guess that the most telling is the following line from ddcprobe. For
  non-correctly-displaying computers: dtiming: 1920x1080@68

  For correctly-displaying computers:  dtiming: 1920x1080@60

  For the record, there is no other ctiming or dtiming line in the
  output of ddcprobe.

  The configuration are otherwise strikingly similar. The other
  differences which seemed of significance (i.e. not mentionning hard
  drives partitions and serial numbers) is that uncorrectly working
  computers have the following extra line in lspci

  00:16.3 Serial controller: Intel Corporation 7 Series/C210 Series
  Chipset Family KT Controller (rev 04)

  Correspondingly, the lshw of these computers have the following extra

               description: Serial controller
               product: 7 Series/C210 Series Chipset Family KT Controller
               vendor: Intel Corporation
               physical id: 16.3
               bus info: pci@0000:00:16.3
               version: 04
               width: 32 bits
               clock: 66MHz
               capabilities: pm msi 16550 bus_master cap_list
               configuration: driver=serial latency=0
               resources: irq:19 ioport:f0e0(size=8) memory:f7d3a000-f7d3afff

  Lastly, in the *-pci section. Also, the *-memory *-bank:n (for n an
  integer) are not of the same vendor (Samsung or Nanya technologies for
  correctly-displaying computers and Hynix/Hyundai for non-correctly-
  displaying ones).

  The visual distortion is roughly as follows: every line gets
  horizontally enlarged by a factor t. This factor varies with time and
  with the height of the line to make nice sine curves out of straight
  vertical lines. Actually there is a phase difference between even and
  odd lines. The leftmost part of the screen remains legible as the
  distortion effect is smaller there but the rightmost part is
  impossible to read. A straight vertical line looks like sine wave, the
  time frequency of this wave varies with time, the amplitude is always
  increasing linearly as one moves to the right of the screen. See also
  the first post in http://ubuntuforums.org/showthread.php?t=2186040

  Do not hesitate to contact me if further testing is of interest.


  ApportVersion: 2.14.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  ubuntu     2324 F.... pulseaudio
  CasperVersion: 1.340
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
   eth0      no wireless extensions.
   lo        no wireless extensions.
  LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: Dell Inc. OptiPlex 9010
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
  ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
   linux-restricted-modules-3.13.0-24-generic N/A
   linux-backports-modules-3.13.0-24-generic  N/A
   linux-firmware                             1.127
  Tags:  trusty
  Uname: Linux 3.13.0-24-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 09/19/2012
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A07
  dmi.board.name: 0CRWCR
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A01
  dmi.chassis.type: 13
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA07:bd09/19/2012:svnDellInc.:pnOptiPlex9010:pvr01:rvnDellInc.:rn0CRWCR:rvrA01:cvnDellInc.:ct13:cvr:
  dmi.product.name: OptiPlex 9010
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: