← Back to team overview

kernel-packages team mailing list archive

[Bug 1199059] Re: blueman and pulse's module-bluetooth-discover (A2DP audio sink devices failed to work with "bluetoothd : Unable to select SEP" in system log.)


I am using a fresh installed Xubuntu 14.04 LTS, after running Ubuntu 10.04 LTS for quite a while on the same laptop Lenovo R500.
Everything worked great after installation, until I came to blueman...
Connecting to two different audio-devices( headset nokia 905i+, bluetooth-speaker DOSS Alonso ) that I own was buggy.
To be more specific: connecting and pairing worked, but there was no sink for pulseaudio available and A2DP setting was not possible.
I followed the discussion:  https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1283003.

And here I could finally find the solution:

it seemed that blueman unloads "module-bluetooth-discover" on startup.

David Henningsson (diwic) found the code in 

he did a quick ppa on that, which unfortunately didn't work

now what?

since I liked the idea, I hacked directly in to that modul
/usr/lib/python2.7/dist-packages/blueman/plugins/applet/PulseAudio.py  line: 229
				if v["name"] == "module-bluetooth-discoverX":
the 'X' is my add-on, since I have no idea about python ;)


now it works! :)

connected my Headset, could set the A2DP and listen to my music right

maybe somebody can use this information to build a real fix. looking
forward to that

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  blueman and pulse's module-bluetooth-discover (A2DP audio sink devices
  failed to work with "bluetoothd : Unable to select SEP" in system

Status in Blueman - Bluetooth Manager:
Status in “blueman” package in Ubuntu:
Status in “bluez” package in Ubuntu:
Status in “pulseaudio” package in Ubuntu:
Status in “bluez” package in Debian:
  Fix Released

Bug description:
  All my A2DP profile devices can't create a audio device properly...
  My 2 13.04 machines both have this issue(1 notebook, 2 bluetooth dongles)
  UPDATE: Upgraded to 13.10, still reproducible

  Possible root cause & fix: Please refer #15

  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: bluez 4.101-0ubuntu8b1
  ProcVersionSignature: Ubuntu 3.8.0-21.32-generic 3.8.8
  Uname: Linux 3.8.0-21-generic x86_64
  ApportVersion: 2.9.2-0ubuntu8.1
  Architecture: amd64
  Date: Tue Jul  9 01:01:38 2013
  InstallationDate: Installed on 2013-01-26 (162 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130126)
  InterestingModules: rfcomm bnep btusb bluetooth
  MachineType: System manufacturer System Product Name
  MarkForUpload: True
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-21-generic root=UUID=9bce9679-da3a-44fd-84ec-b16339a84004 ro quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: Upgraded to raring on 2013-03-01 (128 days ago)
  dmi.bios.date: 08/18/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1101
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: P7H55-M
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1101:bd08/18/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP7H55-M:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
   hci0:	Type: BR/EDR  Bus: USB
    BD Address: 00:15:83:54:59:9F  ACL MTU: 310:10  SCO MTU: 64:8
    RX bytes:29508 acl:1270 sco:0 events:461 errors:0
    TX bytes:5249 acl:165 sco:0 commands:95 errors:0

To manage notifications about this bug go to: