← Back to team overview

kernel-packages team mailing list archive

[Bug 182473] Re: rtl8187 drops connection


*** This bug is a duplicate of bug 215802 ***

it is funny or sad :) that this bug still persists :(

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  rtl8187 drops connection

Status in The Linux Kernel:
Status in “linux” package in Ubuntu:
  In Progress
Status in “lynx” package in Ubuntu:

Bug description:
  I have a ASUS P5K motherboard with integrated wireless based on
  rtl8187.  In Hardy (haven't tried other Ubuntu versions) the
  connection often suddenly fails, with the software not noticing

  Nothing is logged in dmesg or syslog except for (sometimes):  WEP decrypt failed (ICV)
  I have noticed this string also appears in the log at times when the interface does _not_ fail.  

  The computer continues on oblivious to the fact that it has just lost
  its network connection (networkmanager is not installed, but gnome's
  network monitor applet indicates a good connection).  In fact, a
  wireshark dump indicates that the computer still thinks it is sending
  802.11 frames, but monitoring from another computer (with a reliable
  wireless driver) indicates that nothing is being sent from the
  affected computer, even while the AP is chugging along trying to
  contact a host which has mysteriously dropped offline.  I have noticed
  this problem across kernel images (2.6.24-3-generic and
  2.6.24-4-generic to be specific).  In one instance, I found that
  modprobing the module out and back in again fixed it, while another
  time this caused modprobe to use 100% CPU and become unresponsive,
  even to kill signals (Yeah, the kill -9 kind).

  If any more information is necessary please ask and I'll do my best.

  This also effects Intrepid Ibex/2.6.27-7-generic

To manage notifications about this bug go to: