← Back to team overview

kernel-packages team mailing list archive

[Bug 1289238] [NEW] [Dell Inspiron 7737] Wireless key is not working


You have been subscribed to a public bug:

CID: 201306-13869 Dell Inspiron 7737

The wireless key is not working on this system.
1, Install 12.04.4 + update
2. Try to disable the wireless network by pressing the wireless key

Expected result:
* Wireless network should be disabled.

Actual result:
* Nothing happened

Debug information:
ubuntu@201306-13869:~$ sudo showkey -k
kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode  28 release
keycode 240 press
keycode 240 release
keycode 240 press
keycode 240 release
^Ccaught signal 2, cleaning up...

xev.log attached.

For the kernel 3.14rc2 tested in bug 1280063, bug 1219652
Cannot be used on this system, it will stuck on boot with message "unable to find transceiver"
So I verified with 3.13.0, 3.13.6 kernel, they didn't changing anything.
Also tried with the tweak "options dell_laptop force_rfkill=1" in bug 1280063, still not working

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.11.0-17-generic 3.11.0-17.31~precise1
ProcVersionSignature: Ubuntu 3.11.0-17.31~precise1-generic
Uname: Linux 3.11.0-17-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.11.0-17-generic.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
 **** List of CAPTURE Hardware Devices ****
 card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 /dev/snd/controlC1:  ubuntu     1720 F.... pulseaudio
 /dev/snd/controlC0:  ubuntu     1720 F.... pulseaudio
CRDA: Error: [Errno 2] 沒有此一檔案或目錄
 Card hw:0 'MID'/'HDA Intel MID at 0xd0610000 irq 63'
   Mixer name	: 'Intel Haswell HDMI'
   Components	: 'HDA:80862807,80860101,00100000'
   Controls      : 21
   Simple ctrls  : 3
 Card hw:1 'PCH'/'HDA Intel PCH at 0xd0614000 irq 64'
   Mixer name	: 'Realtek ALC283'
   Components	: 'HDA:10ec0283,102805fb,00100003'
   Controls      : 24
   Simple ctrls  : 12
Date: Fri Mar  7 17:19:38 2014
HibernationDevice: RESUME=UUID=ca1e13ff-9c76-4b3d-963a-78920f56fd50
InstallationMedia: Ubuntu 12.04.4 LTS "Precise Pangolin" - Release amd64 (20140204)
MachineType: Dell Inc. Inspiron 7737
MarkForUpload: True
 PATH=(custom, no user)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-17-generic root=UUID=d5c52715-8f14-4117-8f03-9ed38ff6bc99 ro quiet splash vt.handoff=7
 linux-restricted-modules-3.11.0-17-generic N/A
 linux-backports-modules-3.11.0-17-generic  N/A
 linux-firmware                             1.79.10
SourcePackage: linux-lts-saucy
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/27/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd11/27/2013:svnDellInc.:pnInspiron7737:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Inspiron 7737
dmi.sys.vendor: Dell Inc.

** Affects: linux (Ubuntu)
     Importance: Low
     Assignee: Edward Lin (airken)
         Status: Fix Committed

** Tags: 201306-13869 amd64 apport-bug certification-grey function-keys precise qa-kernel-lts-testing running-unity taipei-lab
[Dell Inspiron 7737] Wireless key is not working
You received this bug notification because you are a member of Kernel Packages, which is subscribed to linux in Ubuntu.