← Back to team overview

kernel-packages team mailing list archive

[Bug 1332727] Status changed to Confirmed


This change was made by a bot.

** Changed in: linux (Ubuntu)
       Status: New => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  X stutters (high IO wait) by running this specific scenario

Status in “linux” package in Ubuntu:

Bug description:
  As nothing changed, I'll just copy-paste(and update) what I said in
  bugs.launchpad.net/ubuntu/+source/linux/+bug/986831 :

  I can reproduce consistently and a almost at will the "NVRM:
  os_schedule: Attempted to yield the CPU while in atomic or interrupt
  context" problem:

  Ubuntu: x64, 13.10, kernel 3.11.0-23-generic;
  HD SSD OCZ octane 128GB.
  Intel Q9400;
  Motherboard: P5n-D;
  Memory: 2x Macrovision 5-5-5-18; 2x2GB
                   2x Kingston 6-5-5-18; 2x2GB
  --->running in successfull Dual Channel 8GB 6-5-5-18;
  GPU 1: 9600 GT 512MB;
  GPU 2: 9600 GT 512MB;
  --->running in successful SLI;
  --->running using nvidia drivers 319 proprietary.
  PSU: Corsair CX600 V2 (does not look like a problem).

  How I reproduce the problem:

  1)Run World of Warcraft (via Wine-any Wine that works WoW x32 will do, I tried with 1.4 and 1.5-), go to the latest levels (pandaria).
  2)Open any browser and go to youtube, let it running videos from any playlist.
  3)Soon after, the X server will start to stutter, and DMESG will show the "NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context" problem.
  4)Usually, if I get to catch the problem, the kernel process that switches processes around (mostly the first of 4) called migration (in my case, migration/0) will appear running at 100%.

  If I run just the game or just the browser, everything runs perfectly.
  SLI works randomly for WoW if running in full screen. SLI is always
  working while in Unity.

  If I try to run GPU testers like furmark (for linux) under the same
  conditions I cannot reproduce the problem.

  BUT: After running the "ubuntu-bug linux" and in dmesg appeared this:
  "Watchdog[18072]: segfault at 0 ip 00007f308b0c1738 sp 00007f307c6026f0 error 6 in libcontent.so[7f308a979000+fb2000]"
  everything is working fine now?! I don't know what happened, all that I always do when the problem happens, I go to  tty1 and run top, go to tty2 and run tail -f /var/log/syslog, and keep switching between 1, 2 and 7.

  I hope this helps someone.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.10
  Package: linux-image-3.11.0-23-generic 3.11.0-23.40
  ProcVersionSignature: Ubuntu 3.11.0-23.40-generic
  Uname: Linux 3.11.0-23-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.12.5-0ubuntu2.2
  Architecture: amd64
   /dev/snd/controlC0:  jp        11781 F.... pulseaudio
   /dev/snd/pcmC0D0p:   jp        11781 F...m pulseaudio
   /dev/snd/controlC1:  jp        11781 F.... pulseaudio
   /dev/snd/controlC2:  jp        11781 F.... pulseaudio
  Date: Fri Jun 20 18:34:24 2014
  HibernationDevice: RESUME=UUID=23553401-e27e-454f-aa54-74f2b8788037
  InstallationDate: Installed on 2014-03-26 (86 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  MachineType: System manufacturer System Product Name
  MarkForUpload: True

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-23-generic root=UUID=676c6842-6552-45df-86d8-09a797e3dffe ro quiet splash
   linux-restricted-modules-3.11.0-23-generic N/A
   linux-backports-modules-3.11.0-23-generic  N/A
   linux-firmware                             1.116.2
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 06/21/2010
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: ASUS P5N-D ACPI BIOS Revision 1401
  dmi.board.name: P5N-D
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: 1.XX
  dmi.chassis.asset.tag: 123456789000
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSP5N-DACPIBIOSRevision1401:bd06/21/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5N-D:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: