← Back to team overview

kernel-packages team mailing list archive

[Bug 1331860] Re: [Gigabyte GA-MA770-UD3] wireless lags


dev-rke, this bug report is being closed due to your last comment
regarding this being fixed with an update. For future reference you can
manage the status of your own bugs by clicking on the current status in
the yellow line and then choosing a new status in the revealed drop down
box. You can learn more about bug statuses at
https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time
to report this bug and helping to make Ubuntu better. Please submit any
future bugs you may find.

** Changed in: linux (Ubuntu)
       Status: Incomplete => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Gigabyte GA-MA770-UD3] wireless lags

Status in “linux” package in Ubuntu:

Bug description:

  i already discussed the following issue already in the german forum
  and in your Official Ubuntu IRC Support Channel, without a solution.

  new Ubuntu: 14.04 LTS
  new Kernel: 3.13.0-29-generic
  old Ubuntu: 13.10
  old Kernel: 3.11.0-19-generic

  wireless device: TP-LINK WND4800, Atheros chipset
  wireless driver: ath9k
  wireless operating mode: 2.4ghz @ 802.11bgn and 5ghz @ 802.11a+n
  wireless router: fritz!box 3390

  Before upgrading to Ubuntu 14.04 LTS everything worked fine.
  After upgrading to Ubuntu 14.04 LTS the wireless connection produced sequently lags, when sending a ping to my wireless router.
  The lag sequence duration is around 5 seconds, the duration to the next lag sequence is around 100 seconds.
  Each ping get a reply (no requests get lost), but the delay of the reply raises up to 2000 miliseconds. 
  Normally the ping is around 1 or 2 miliseconds.
  I can reproduce this behavior manually by running 'sudo iwlist wlan1 scan' and keep watching the ping in another terminal window.
  I also used 'iwevent' to watch on events fired by the wireless interface while the lag is happening:
  '01:31:13.289166   wlan1    Scan request completed' is the only message i get.

  When booting the 3.11 kernel everything works fine again, no lags occur.
  If i try to reproduce the behavior with a manual scan as described before, no lags occur, everything keeps working fine.

  I already tried several configurations using special driver options like "nohwcrypt" and "debug", but dmesg and syslog do not log any failures or warnings.
  If i downgrade the wireless router to 2.4ghz @ 802.11b+g (54mbit) the new kernel (3.13) has also no failed pings and no massive lags, but this is not a stable solution for me due to many other wireless networks in my environment.

  So i assume there has been something changed between the kernel 3.11 and 3.13 or the belonging ath9k driver.
  I thought about the wireless scanning interval of the network manager, but i think changing this would also be just a workaround than a clean solution.

  Any ideas or recommendations how to solve this or how to collect more relevant information about this issue?
  ApportVersion: 2.14.1-0ubuntu3.2
  Architecture: i386
   /dev/snd/controlC1:  reiner     3154 F.... pulseaudio
   /dev/snd/controlC0:  reiner     3154 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=79cac639-2340-43af-8d11-807382480b49
  InstallationDate: Installed on 2012-03-17 (824 days ago)
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
  MachineType: Gigabyte Technology Co., Ltd. GA-MA770-UD3
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-29-generic root=UUID=59541979-590e-42ca-a568-79027794148f ro quiet splash
  ProcVersionSignature: Ubuntu 3.13.0-29.53-generic
   linux-restricted-modules-3.13.0-29-generic N/A
   linux-backports-modules-3.13.0-29-generic  N/A
   linux-firmware                             1.127.2
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  Tags:  trusty
  Uname: Linux 3.13.0-29-generic i686
  UpgradeStatus: Upgraded to trusty on 2014-04-21 (59 days ago)
  UserGroups: adm admin cdrom dialout fuse lpadmin mythtv plugdev sambashare wireshark www-data
  _MarkForUpload: True
  dmi.bios.date: 12/29/2009
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: FG
  dmi.board.name: GA-MA770-UD3
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrFG:bd12/29/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA770-UD3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA770-UD3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-MA770-UD3
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: