← Back to team overview

kernel-packages team mailing list archive

[Bug 1335691] Missing required logs.


This bug is missing log files that will aid in diagnosing the problem.
>From a terminal window please run:

apport-collect 1335691

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

** Tags added: trusty

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Server 14.04 does not set static IPv6 addresses on interfaces when
  auto-config options are turned off

Status in “linux” package in Ubuntu:

Bug description:
  On Ubuntu server 14.04 (upgraded from 13.10) I am trying to get rid of
  the IPv6 auto-config addresses and leave on my statically assigned
  ones. The system has two interfaces, a physical eth0 and vlan10.

  1. privext 0 in /etc/network/interfaces

  When I set the "privext 0" option for both interfaces in
  /etc/network/interfaces, then vlan10 does not get the configured
  static IPv6 address. It only gets the IPv6 link local address.
  However, eth0 is configured as expected with just the given static

  Using "privext 0" on only one or the other, but not both, worked as

  2.  net.ipv6.conf.*.use_tempaddr = 0 in /etc/sysctl.conf

  If I add both net.ipv6.conf.eth0.use_tempaddr = 0 and
  net.ipv6.conf.vlan10.use_tempaddr = 0 of /etc/sysctl.conf, then the
  situation is reversed. Vlan10 is configured as expected with just its
  given address and eth0 has only the link-local address.

  If I add only net.ipv6.conf.eth0.use_tempaddr = 0, then again eth0
  only gets the link local address and not the assigned static.

  On using net.ipv6.conf.vlan10.use_tempaddr = 0, then everything ended
  up as expected - eth0 had the auto-config addresses plus its static
  address and vlan10 only had the static address.

  1 + 2 kludging attempt:

  Unfortunately, combining net.ipv6.conf.vlan10.use_tempaddr = 0 in
  sysctl.conf and "privext 0" in /etc/network/interfaces for eth0, both
  of which worked as expected alone, did not work togther. The result
  was the same as setting net.ipv6.conf.*.use_tempaddr = 0 on bothg, as
  mentioned above.

  3.  net.ipv6.conf.*.use_tempaddr = 0 in /etc/sysctl.conf

  Using net.ipv6.conf.*.autoconf = 0 resulted in eth0 getting only it's
  static address as expected, but vlan10 was still given the autoconfig

  Using only net.ipv6.conf.vlan10.autoconf = 0 had no effect, the
  interface still go the auto-config addresses. Using only
  net.ipv6.conf.eth0.autoconf = 0 did work.

  2 + 3 kludging attempt:

  What finally worked was the combination of
  net.ipv6.conf.vlan10.autoconf = 0 and
  net.ipv6.conf.vlan10.use_tempaddr = 0


  So it looks like that of all thee three methods one can potentially
  use to get rid of IPv^ auto-config addresses, one simply doesn't work
  on vlan interfaces and the other two have weird transitive side
  effects when applied at the same time to a parent physical interface
  and a child vlan interface when one would expect them to be entirely

To manage notifications about this bug go to: