← Back to team overview

kernel-packages team mailing list archive

[Bug 1268848] Re: Unity in 13.10 unstable with Radeon 7950


** Changed in: unity (Ubuntu)
       Status: Incomplete => New

** Package changed: unity (Ubuntu) => linux (Ubuntu)

** Changed in: linux (Ubuntu)
       Status: New => Fix Released

** Changed in: unity
       Status: Incomplete => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Unity in 13.10 unstable with Radeon 7950

Status in Unity:
Status in “linux” package in Ubuntu:
  Fix Released

Bug description:
  About a month ago I installed a fresh Ubuntu 13.10 64bit on a i5
  machine, 8GB RAM, with Radeon 7950 graphic card. Before this, I was
  running 12.04 64bit without any graphic driver related problems.

  I tried both Catalyst versions from official repository, latest 13.12
  drivers from AMD site and open source drivers (radeon), and I can't
  tell which one was more unstable. After a few hours of use, I could
  not play any videos with any of the drivers (tried mplayer and VLC,
  both crashed with various errors), OpenGL isn't working anymore (even
  glxgears was crashing) and I had various artifacts on screen (like
  parts of window rendered on the wrong place on screen). Putting
  machine to sleep and waking it up later produced even more errors. I
  also tried to turn off various things in CCSM, without any positive
  results. Steam client had terrible flickering almost all the time, it
  was practically unusable; also about 8 of 10 times it was crashing on

  After about two weeks of trying to make it usable, I gave up and
  installed MATE desktop. Not a single graphic error since then. Steam
  works flawlessly, 3D games also, Wine games, playing videos,

  I kind of like how Unity works, I was using it for the last two years
  as my main desktop (on the same machine), but this behaviour is
  unexpected and utterly undesireable.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.10
  Package: unity 7.1.2+13.10.20131014.1-0ubuntu1
  ProcVersionSignature: Ubuntu 3.11.0-15.23-generic 3.11.10
  Uname: Linux 3.11.0-15-generic x86_64
  NonfreeKernelModules: fglrx
  ApportVersion: 2.12.5-0ubuntu2.2
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  Date: Tue Jan 14 07:26:14 2014
  DistUpgraded: Fresh install
  DistroCodename: saucy
  DistroVariant: ubuntu
   fglrx, 13.251, 3.11.0-14-generic, x86_64: installed
   fglrx, 13.251, 3.11.0-15-generic, x86_64: installed
   vboxhost, 4.3.6, 3.11.0-14-generic, x86_64: installed
   vboxhost, 4.3.6, 3.11.0-15-generic, x86_64: installed
   Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950] [1002:679a] (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:0424]
  InstallationDate: Installed on 2013-12-06 (38 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
   kmod:fglrx - ATI Fire GL (Proprietary, Enabled, In use)
   kmod:fglrx_updates - Video driver for the AMD graphics accelerators (Proprietary, Disabled, Not in use)
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  MarkForUpload: True
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-15-generic root=UUID=eab5c9d7-0979-4fae-9ed5-a26a530694de ro quiet splash vt.handoff=7
  SourcePackage: unity
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/08/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P1.00
  dmi.board.name: Z68 Extreme4 Gen3
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.00:bd07/08/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ68Extreme4Gen3:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.
  version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
  version.fglrx-installer: fglrx-installer N/A
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.46-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 9.2.1-1ubuntu3
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 9.2.1-1ubuntu3
  version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2~saucy1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu10
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.904-0ubuntu2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
  xserver.bootTime: Fri Jan 10 14:53:12 2014
  xserver.configfile: /etc/X11/xorg.conf
  xserver.logfile: /var/log/Xorg.0.log
  xserver.version: 2:1.14.5-1ubuntu2~saucy1
  xserver.video_driver: fglrx

To manage notifications about this bug go to: