← Back to team overview

kernel-packages team mailing list archive

[Bug 1344405] Re: Kernel missing /proc/keys


I had the same problem and have tried the same remedy, increasing the parameters and rebuld kernel 
I did this with 3.13.0-34 on a ubuntu 14.04 client which was running already this kernel in which it was
not fixed.

When can we expect this to be present in a trusty kernel update ?
We are experiencing a lot of trouble with this since we are migrating more machines
to 14.04.
We had and still have the same problem but a lot less frequently on 12.04 clients.
Is the same fix expected to work ?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Kernel missing /proc/keys

Status in “linux” package in Ubuntu:
  Fix Released
Status in “linux” source package in Trusty:
  Fix Committed
Status in “linux” source package in Utopic:
  Fix Released

Bug description:
  lsb_release -rd
  Description:       Ubuntu 14.04 LTS
  Release:              14.04

  apt-cache policy linux-generic

    Version table: 0
          500 http://ca.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
          500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
   *** 0
          500 http://ca.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
          100 /var/lib/dpkg/status


  When attempting to clear NFS uid/gid cache I ran nfsidmap -c

  expected Result
  no response, nfsidmap does not return anything if it completes properly

  [root@quebec ~]# nfsidmap -c
  [root@quebec ~]#

  What did happen

  root@u1404vm:~# nfsidmap -c
  nfsidmap: fopen(/proc/keys) failed: No such file or directory

  I checked /proc and the /proc/key-users file and the
  /proc/sys/kernel/keys directory were there.

  I Looked up Kernel Key Management and saw that /proc/keys was needed
  to hold the key pairs used by the kernel.

   From Google'ng the following kernel option needs to be enabled


  or /proc/keys does not get created.

  I checked /boot/config-3.13.0-24-generic and that option is not

  I checked this on both Centos 6.5/7 and Mageia and they are enabled
  and /proc/keys exist, nfsidmap -c works.

To manage notifications about this bug go to: