← Back to team overview

kernel-packages team mailing list archive

[Bug 1328587] Re: [HDA-Intel - HDA Intel PCH, recording] External microphone not recognized


This bug is awaiting verification that the kernel in -proposed solves
the problem. Please test the kernel and update this bug with the
results. If the problem is solved, change the tag 'verification-needed-
precise' to 'verification-done-precise'.

If verification is not done by 5 working days from today, this fix will
be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
to enable and use -proposed. Thank you!

** Tags added: verification-needed-precise

** Tags added: verification-needed-trusty

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [HDA-Intel - HDA Intel PCH, recording] External microphone not

Status in “linux” package in Ubuntu:
  Fix Released
Status in “linux” source package in Precise:
Status in “linux” source package in Trusty:

Bug description:
  With my Fujitsu U904 laptop with the headset jack (an icon with a
  headset next to it) and Ubuntu 14.04, external microphone is not
  detected when attached to the headset jack (through a TRRS splitter I

  I had to override pin 0x19 with hda-jack-retask from alsa-tools-gui to
  get my external microphone to work, when it was autodetected. I've
  also tried with a random Nokia headset I had around (from N900 or N9),
  and overriding pin 0x19 made it work properly as well.

  Before overriding, I had "Microphone (internal)" and "Analog input
  (internal)" shown as input devices, yet my laptop only has a single
  headset jack.

  Judging from other bugs, it's David Henningsson (diwic) who usually
  handles these so I'll subscribe him directly.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: pulseaudio 1:4.0-0ubuntu11
  ProcVersionSignature: Ubuntu 3.13.0-29.53-generic
  Uname: Linux 3.13.0-29-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.2
  Architecture: amd64
   /dev/snd/pcmC1D0c:   danilo     5803 F...m pulseaudio
   /dev/snd/controlC1:  danilo     5803 F.... pulseaudio
   /dev/snd/controlC0:  danilo     5803 F.... pulseaudio
                        danilo    31342 F.... audacity
  CurrentDesktop: Unity
  Date: Tue Jun 10 17:35:35 2014
  EcryptfsInUse: Yes
  SourcePackage: pulseaudio
  Symptom: audio
  Symptom_Card: HDA-Intel - HDA Intel PCH
  Title: [HDA-Intel - HDA Intel PCH, recording] Pulseaudio fails to detect card
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/11/2013
  dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
  dmi.bios.version: Version 1.07
  dmi.board.name: FJNB27D
  dmi.board.vendor: FUJITSU
  dmi.board.version: D2
  dmi.chassis.type: 10
  dmi.chassis.vendor: FUJITSU
  dmi.chassis.version: LIFEBOOK U904
  dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.07:bd12/11/2013:svnFUJITSU:pnLIFEBOOKU904:pvr10601115935:rvnFUJITSU:rnFJNB27D:rvrD2:cvnFUJITSU:ct10:cvrLIFEBOOKU904:
  dmi.product.name: LIFEBOOK U904
  dmi.product.version: 10601115935
  dmi.sys.vendor: FUJITSU

To manage notifications about this bug go to: