← Back to team overview

kernel-packages team mailing list archive

[Bug 1380824] Re: Backlight not working on Samsung ATIV 8 laptop


Same effect on my Samsung Ativ Book 7 (intel i7 intel/ati hybrid)
neither radeon, nor fglrx is working. Kernels 3.13.0-37, 3.16.0-23/24
don't work. Everything worked unter Xubuntu 14.04 (under 14.04
acpi_backlight=vendor even turned on brightness sensor) Under 14.10 ONLY
brightness sensor works and cannot be turned off. Brightnesse keys tell
me they are working by notification bubbles but screen stays at 100%.
xbacklight does not decrease brightess although it tells me it it
running at 50% (screen still 100%)

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Backlight not working on Samsung ATIV 8 laptop

Status in “linux” package in Ubuntu:

Bug description:
  I have a 15" Samsung ATIV Book 8 laptop, np870z5e model from 2013.
  It features an Intel core-i7 cpu, and integrated Intel Hd4000 video card and also an ATI Radeon video card.

  According to Backlight debugging page[1], my case is 
  "Backlight control does not work, but there are entries in /sys/class/backlight. "

  What works:
  Fn-F2, Fn-F3 keys works(Brightness down, brightness up), 
  shows the brightness notification dialog, and also the
  /sys/class/backlight/intel_backlight/actual_brightness file changes too.
  It has no physical effect.

  It does not have any physical effect (brightness does not change), 
  up until the brightness notification is zero (no bar on it), then the display switches off. 
  raising the brightness switches the display back to the same brightness it was, 
  and still not have any effect to the brightness.

  Semi works:
  Powering on the laptop starts with about 60% brightness.
  If I suspend-resume the laptop, it results 100% brightness.
  If I unplug the power cord (if it was plugged in when the laptop started), then it results 100% brightness.
  If I plug the power cord (if it was unplugged when the laptop started), then it results 100% brightness.

  I can't change the 100% brightness afterwards.

  What I have tried:
  a) xorg.conf file:

  # Fix Backlight issue
  Section "Device"
  	Identifier  "card0"
  	Driver      "intel"
  	Option      "Backlight"  "intel_backlight"
  	BusID       "PCI:0:2:0"

  No effect.

  b) Kernel boot parameter in /etc/defaults/grub
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=0"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_bios_initial_backlight=0"

  I tried each one, with a power off - power on cycle, but none of it had any effect.
  I doublechecked it (after boot), with cat /proc/cmdline.

  Changing the /sys/class/backlight/intel_backlight/brightness values, 
  has no physical effect, although the file do change (checked with cat).

  I'm desperately trying to solve this issue, because the screen is always at full brightness, 
  and burns my eyes out. (300cd/m2 screen is extremely bright).

  Any help is much appreciated.

  [1]: https://wiki.ubuntu.com/Kernel/Debugging/Backlight

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: linux-image-3.16.0-21-generic 3.16.0-21.28
  ProcVersionSignature: Ubuntu 3.16.0-21.28-generic 3.16.4
  Uname: Linux 3.16.0-21-generic x86_64
  ApportVersion: 2.14.7-0ubuntu5
  Architecture: amd64
   /dev/snd/controlC0:  lama       2528 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Tue Oct 14 00:38:17 2014
  InstallationDate: Installed on 2014-01-13 (273 days ago)
  InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 870Z5E/880Z5E/680Z5E
   0 inteldrmfb
   1 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-21-generic.efi.signed root=UUID=ba121a25-b094-49f5-96bf-ade769938060 ro quiet splash video.use_bios_initial_backlight=0 vt.handoff=7
   linux-restricted-modules-3.16.0-21-generic N/A
   linux-backports-modules-3.16.0-21-generic  N/A
   linux-firmware                             1.135
  SourcePackage: linux
  UpgradeStatus: Upgraded to utopic on 2014-10-08 (5 days ago)
  dmi.bios.date: 06/04/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P02ADH.008.130604.SK
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: NP870Z5E-X01HU
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: SEC_SW_REVISION_1234567890ABCD
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP02ADH.008.130604.SK:bd06/04/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn870Z5E/880Z5E/680Z5E:pvrP02ADH:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP870Z5E-X01HU:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
  dmi.product.name: 870Z5E/880Z5E/680Z5E
  dmi.product.version: P02ADH
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to: