← Back to team overview

kernel-packages team mailing list archive

[Bug 1386473] Re: Not using all cores after upgrade to 14.10


I installed 13.16.6 and it uses all cores. The bug is not present in
that kernel version.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Not using all cores after upgrade to 14.10

Status in “linux” package in Ubuntu:
Status in “linux” source package in Utopic:

Bug description:
  I have a computer with two cpus with 4 cores each (physical) but htop
  is only showing activity on two of these 8 cores (number 1 and 3).
  Also, if I run "stress -c 8" top shows only 25% cpu usage. I've
  rebooted the machine and the problem persists. I also took a look at
  the BIOS settings and found nothing there that looked suspicious.

  If I run 'stress -c 8' only two cores go to 100% in htop as stated
  above (cores 1 and 3). If I run 'stress -c 1', one core goes to 100%
  (either core 1 or 3). If I run taskset -cp <coreid> <pid> I can
  control which core the process is run on. I can actually move it to
  any core that I want (1, 3 or any other one)! So the cores are
  there... the kernel just doesn't seem to use it unless I explicitly
  tell it to with taskset.

   I've verified that this is a regression when moving from [lxk]ubuntu
  14.04 to 14.10. I used pristine lubuntu 14.10 and 14.04 usb sticks to
  test this out and verified that a cpu sysbench test using 8 threads
  took ~15 sec on 14.04 but ~55 sec on 14.10. The computer this is
  happening on is a Dell Precision T5400 tower workstation.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: linux-image-3.16.0-23-generic 3.16.0-23.31
  ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
  Uname: Linux 3.16.0-23-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.14.7-0ubuntu8
  Architecture: amd64
  CRDA: Error: [Errno 2] No such file or directory: 'iw'
  CurrentDesktop: KDE
  Date: Tue Oct 28 00:46:25 2014
  HibernationDevice: RESUME=UUID=20536d9f-ef05-46dd-a104-47367e464fcd
  InstallationDate: Installed on 2014-02-05 (264 days ago)
  InstallationMedia: Ubuntu-Server 13.10 "Saucy Salamander" - Release amd64 (20131016)
   eth0      no wireless extensions.
   lo        no wireless extensions.
  MachineType: Dell Inc. Precision WorkStation T5400
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-23-generic root=UUID=28fc4c4c-cecd-4abe-a788-28f69e745845 ro splash quiet
   linux-restricted-modules-3.16.0-23-generic N/A
   linux-backports-modules-3.16.0-23-generic  N/A
   linux-firmware                             1.138
  SourcePackage: linux
  UpgradeStatus: Upgraded to utopic on 2014-10-24 (3 days ago)
  dmi.bios.date: 02/01/2008
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A01
  dmi.board.name: 0RW203
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 7
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA01:bd02/01/2008:svnDellInc.:pnPrecisionWorkStationT5400:pvr:rvnDellInc.:rn0RW203:rvrA00:cvnDellInc.:ct7:cvr:
  dmi.product.name: Precision WorkStation T5400
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: