← Back to team overview

kernel-packages team mailing list archive

[Bug 1388786] Re: TCP stale transfer with erroneous SACK information


Ah, in that case you probably wanted to report a bug against the linux
package in Ubuntu. I'll move it across.

** Project changed: launchpad => linux (Ubuntu)

** Changed in: linux (Ubuntu)
       Status: Invalid => New

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  TCP stale transfer with erroneous SACK information

Status in “linux” package in Ubuntu:

Bug description:
  Cisco PIX/FWSM changes TCP sequence numbers but doesn't change numbers
  in SACK TCP options.

  When this erroneous information comes to Linux server there is some
  corruption in TCP stack in some circunstances with CUBIC TCP
  congestion algorithm and transfer stales.

  Problem can be reproduced in Ubuntu Server 14.04 when a Cisco FWSM is
  changing sequence numbers (default configuration) and a big file
  (30MB, for example) is being transfered.

  Can be solved deactivating SACK:
  sysctl -w net.ipv4.tcp_sack=0

  We have solved it also with this configuration:
  sysctl -w net.ipv4.tcp_congestion_control=reno
  sysctl -w net.ipv4.tcp_frto=1
  sysctl -w net.ipv4.tcp_early_retrans=1

  We can also fix  it by changing firewall configuration.

  Find attached a wireshark capture where you can see at 16613 frame how
  client requests segment 853521869 and server ( resends
  again a previous segment for 87 seconds until it stops transfer.


To manage notifications about this bug go to: