← Back to team overview

kernel-packages team mailing list archive

[Bug 1102797] Re: 04c5:11a2 Fujitsu ScanSnap S1500 does not work on USB3 ports


Christopher (penalvch):

Thank you for your reply. I am not totally sure if you reply means that
I need to install Ubuntu (instead of Mint 17) to file the bug?

As a desperate attempt I bought a USB2.0 PCI-e card and installed it in
my motherboard (Syba PCI-express USB2.0 5 port host controller card).
This has SOLVED my problem (for $23).

If I plug the Fujitsu SnapScan S1500 back into a motherboard USB 2.0
port I get the exact same error as before (bellow).

In summary: I have “solved” this recognition problem of the Fujitsu
SnapScan S1500 in both Mint 16 and Mint 17 with both GA-Z87X-UD3H
Gigabyte motherboard and MSI B85M-G43 motherboard. My solution is to buy
a USB2 PCI-e board. From the posts this happens the same way in Ubuntu
and Mint (I searched but did not find any Mint forum addressing this).
Contrarily to what I previously thought this does not seem to be related
to USB 2.0 vs USB 3.0 (I need a PCI-e USB 3 card to be sure).

Hope my long report is of some help. Let me know if I can help further
without a new install.

$ dmesg
[  872.748353] usb 6-6: Product: ScanSnap S1500
[  872.748354] usb 6-6: Manufacturer: Fujitsu 
[  872.748473] usb 6-6: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes

Again, some system info:
Linux sky 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux, Mint 17, Cinnamon 64 bits 2.2.16
Motherboard: Motherboard MSI B85M-G43  Intel I7-4770 CPU
Graphics card and driver: NVIDIA GK107 GeForce GTX650 Nvidia 331.38-0ubuntu7.1

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  04c5:11a2 Fujitsu ScanSnap S1500 does not work on USB3 ports

Status in “linux” package in Ubuntu:

Bug description:
  I have a Fujitsu ScanSnap S1500.  This scanner worked fine in 12.04,
  32-bit.  I wiped the hard drive and installed 12.10, 64-bit, fresh.
  The scanner has not worked since and I can't figure out why.

  I'm not quite sure which package to put this bug in.  The wiki says
  any hardware problems get assigned to the kernel, but my scanner shows
  up in lsusb and shows up in /var/log/udev.  That makes it sound like
  the hardware is getting seen.

  What doesn't work is sane-find-scanner, xsane, simple-scan, or
  gscan2pdf.  Nothing that actually interfaces with the scanner works.

  Yes, I'm in the scanner and saned groups.

  The USB device ID is 04c5:11a2.  The device is in
  /lib/udev/rules.d/40-libsane.rules.  The backend is enabled in

  The only bug-like event I see anywhere is in dmesg:
  [12864.421157] usb 3-4: new high-speed USB device number 7 using xhci_hcd
  [12864.453163] usb 3-4: New USB device found, idVendor=04c5, idProduct=11a2
  [12864.453167] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
  [12864.453170] usb 3-4: Product: ScanSnap S1500
  [12864.453172] usb 3-4: Manufacturer: Fujitsu
  [12864.453456] usb 3-4: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes
  [12864.453461] usb 3-4: ep 0x2 - rounding interval to 128 microframes, ep desc says 255 microframes

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: sane 1.0.14-9
  ProcVersionSignature: Ubuntu 3.5.0-22.35~pre201301190400-generic
  Uname: Linux 3.5.0-22-generic x86_64
  ApportVersion: 2.6.1-0ubuntu9
  Architecture: amd64
  Date: Tue Jan 22 00:10:19 2013
  EcryptfsInUse: Yes
  MarkForUpload: True
  SourcePackage: sane-frontends
  UpgradeStatus: No upgrade log present (probably fresh install)
  ApportVersion: 2.10.2-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC1:  ubuntu     3113 F.... pulseaudio
                        ubuntu     4968 F.... pulseaudio
   /dev/snd/controlC0:  ubuntu     3113 F.... pulseaudio
                        ubuntu     4968 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  CasperVersion: 1.333
  DistroRelease: Ubuntu 13.10
   eth0      no wireless extensions.
   lo        no wireless extensions.
  LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130615)
  MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
  MarkForUpload: True
  Package: linux (not installed)
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
  ProcVersionSignature: Ubuntu 3.9.0-6.13-generic 3.9.6
   linux-restricted-modules-3.9.0-6-generic N/A
   linux-backports-modules-3.9.0-6-generic  N/A
   linux-firmware                           1.109
  Tags:  saucy
  Uname: Linux 3.9.0-6-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 08/23/2012
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F11
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: B75M-D3H
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF11:bd08/23/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnB75M-D3H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To be filled by O.E.M.
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: