← Back to team overview

kernel-packages team mailing list archive

[Bug 595321] Re: Sata drives not detected by 2.6.35.* kernels


Hi, I've got the same problem like Paul. Ubuntu 14.04.1 32-bit, laptop with ATI 4379 Serial ATA Controller (designed by Silicon Image) and a SanDisk SSD.
I already inserted a SiI3512A in a Desktop-PC with the same results, HDD works fine, SSD can't be accessed in any way.
My Thread on ubuntuusers.de: http://forum.ubuntuusers.de/topic/ubuntu-14-04-1-kann-nicht-auf-ssd-installiert-/ where I posted all details I've tried.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Sata drives not detected by 2.6.35.* kernels

Status in “linux” package in Ubuntu:
  Fix Released

Bug description:
  Possibly a regression in module sata_sil in Maverick. My Sata
  controller is a Silicon Image 3114

  This happens with any .35 version of the kernel, live-cd iso, alt. iso (multiple dailies), and on installed Maverick test rig.
  I've tried 2.6.35-2 , -3, rc3, -999, all fail to boot to install on sata drive. 
  Message is: ALERT! /dev/disk/by-uuid/167aa185-9a1c-490f-8887-310c18a6b21b does not exist. Dropping to a shell!
  Busy Box etc. etc. initramfs_  ls /dev only shows my ide drives, cat /proc/modules shows the sata_sil there.
  I've checked my uuid's, and my grub.cfg for correctness and no errors

  I can boot to the 2.6.34-5 kernel and all is well.

  The live-cd and alt.iso both boot and work but cannot detect sata drives. I have attached the .log files from the live-cd session because I couldn't get the info I needed from the initramfs shell even booting from debug parameter.
  I will try again if need be, but the dmesg.log seems to show the sata error. I'm also giving the output from fdisk -l from the live-cd and the booted .34-5 kernel to clarify the issue.

To manage notifications about this bug go to: