← Back to team overview

kernel-packages team mailing list archive

[Bug 1003743] Re: webcam fails w/ubuntu 12.04 works w/Debian 6 - both x64 OS


brian mullan, is this still an issue for you with the latest kernel in

** Package changed: ubuntu => linux (Ubuntu)

** Changed in: linux (Ubuntu)
   Importance: Undecided => Low

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

** Changed in: linux (Ubuntu)
     Assignee: masoruc (masoruc) => (unassigned)

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  webcam fails w/ubuntu 12.04 works w/Debian 6 - both x64 OS

Status in “linux” package in Ubuntu:

Bug description:
  I've been trying to get my webcam working in 12.04 x64 system.
  Tried all recommendations including tried tools like cheese, guvcview, etc.  they all recognize webcam but no picture

  $ lsusb
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  Bus 001 Device 003: ID 0424:2504 Standard Microsystems Corp. USB 2.0 Hub
  Bus 001 Device 004: ID 0409:005a NEC Corp. HighSpeed Hub
  Bus 002 Device 003: ID 041e:4058 Creative Technology, Ltd Live! Cam Optia AF
  Bus 003 Device 002: ID 0609:031d SMK Manufacturing, Inc. eHome Infrared Receiver
  Bus 005 Device 002: ID 058f:9360 Alcor Micro Corp. 8-in-1 Media Card Reader
  Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
  Bus 001 Device 006: ID 05e3:1205 Genesys Logic, Inc. Afilias Optical Mouse H3003 / Trust Optical USB MultiColour Mouse MI-2330
  Bus 001 Device 007: ID 046d:c318 Logitech, Inc. Illuminated Keyboard

  $ dmesg (partial) shows webcam present
  [   22.205797] Linux video capture interface: v2.00
  [   22.211917] uvcvideo: Found UVC 1.00 device <unnamed> (041e:4058)
  [   22.214094] input: UVC Camera (041e:4058) as /devices/pci0000:00/0000:00:13.2/$
  [   22.214169] usbcore: registered new interface driver uvcvideo
  [   22.214171] USB Video Class driver (1.1.1)

  NOTE #1:  Unity vs Unity 2d issue -- WEBCAM fails in either BUT in Unity 2d there is no picture but at least screen goes from 
                      pure black to colors

  NOTE #2:  I will file a separate bug ... but I think the solution to
  this BUG is related to Adobe Flash Player NOT working also in Ubuntu
  12.04 x64 OS.    MANY people have attached to that Ubuntu Bug AND
  DOZENS of bugs marked duplicates of it.


  Again, only x64 versions of Ubuntu affected.

  I also have screenshots that I can send showing FLASH PLAYER -and-
  Webcam work in Debian 6 x64 -but- both fail in Ubuntu 12.04 x64 with

  I also have a screenshot I can send that shows FLASH PLAYER -is- mouse
  clickable in in Ubuntu 12.04 x64 (even though the webcam still doesn't

  I  wanted to file these 2 bugs because Debian and Ubuntu or so closely
  related that perhaps some DEV can figure out why both these 2 issues
  fail in Ubuntu 12.04 x64 release yet BOTH work in Debian 6 x64

  There are ALOT of people having these 2 problems right now.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: firefox 12.0+build1-0ubuntu0.12.04.1
  ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
  Uname: Linux 3.2.0-24-generic x86_64
  NonfreeKernelModules: fglrx
  AddonCompatCheckDisabled: False
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC2:  bmullan    6015 F.... pulseaudio
   /dev/snd/controlC0:  bmullan    6015 F.... pulseaudio
   /dev/snd/controlC1:  bmullan    6015 F.... pulseaudio
  BuildID: 20120423122928
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
   Card hw:0 'SB'/'HDA ATI SB at 0xfe024000 irq 16'
     Mixer name	: 'Realtek ALC889A'
     Components	: 'HDA:10ec0885,1458a002,00100101'
     Controls      : 49
     Simple ctrls  : 23
   Card hw:1 'U0x41e0x4058'/'Creative Labs USB Device 0x41e:0x4058 at usb-0000:00:13.2-2, high speed'
     Mixer name	: 'USB Mixer'
     Components	: 'USB041e:4058'
     Controls      : 3
     Simple ctrls  : 2
   Card hw:2 'HDMI'/'HDA ATI HDMI at 0xfddfc000 irq 19'
     Mixer name	: 'ATI RS690/780 HDMI'
     Components	: 'HDA:1002791a,00791a00,00100000'
     Controls      : 4
     Simple ctrls  : 1
   Simple mixer control 'IEC958',0
     Capabilities: pswitch pswitch-joined penum
     Playback channels: Mono
     Mono: Playback [on]
  Channel: release
  Date: Wed May 23 21:00:36 2012
  ForcedLayersAccel: False
  IncompatibleExtensions: Hybridfox - ID={2204c510-88f3-11db-b606-0800200c9a66}, Version=1.6.000056, minVersion=2.0, maxVersion=4.2, Location=app-profile, Type=extension, Active=Yes
  InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
   PATH=(custom, user)
  Profiles: Profile0 (Default) - LastVersion=12.0/20120423122928 (Running)
   0: hci0: Bluetooth
   	Soft blocked: no
   	Hard blocked: no
  RunningIncompatibleAddons: True
  SourcePackage: firefox
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/16/2009
  dmi.bios.vendor: Award Software International, Inc.
  dmi.bios.version: F11
  dmi.board.name: GA-MA78GM-S2H
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF11:bd09/16/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA78GM-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA78GM-S2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
  dmi.product.name: GA-MA78GM-S2H
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: