← Back to team overview

kernel-packages team mailing list archive

[Bug 1069111] Re: Wifi working only for brief time, needs reconnecting


Since reporting this (October 2012) I upgraded Ubuntu and I'm currently
using Utopic Unicorn. I'm not experiencing this issue any more.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Wifi working only for brief time, needs reconnecting

Status in “linux” package in Ubuntu:

Bug description:
  I recently upgraded to Ubuntu 12.10 (64bit) and I've run into a problem with the wireless connection. It connects as normal but after a brief time (1 minute at max) it looks like I'm not connected any more. Pages in Chromium stop loading, Dropbox stops syncing, Empathy tells me I need to reconnect, and apparently I need to re-authorize Google online accounts (but the appropriate page fails to load if I try).

  The system doesn't report any errors, however. It tells me that I'm
  still connected with normal signal.

  If I try reconnect to the same network, the symptoms disappear (I can
  load pages, reconnect to Empathy and so on) but after a very brief
  time they reappear as before.

  Everything works fine on other devices connected to the same network,
  and I could use the internet normally when I had Ubuntu 12.04
  installed on the same computer showing the error.

  This bug is very similar to the one reported by Carnalbeast in comment #16 on the following bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/997774
  The only difference is time (I can use the internet for about a minute at most). I could not find a bug report about it, however.

  I discovered similarities with Bug #997774 as well:
  - disabling ipv6 seems to work
  - kernel v3.2.17 (suggested there) works perfectly, even with ipv6 enabled; I've not yet tried other kernels

  However, bug #997774 has been solved by updating the default kernel, while my problem has not. Also, as I understand it, in bug #997774 the system actually disconnected, while in my case everything is apparently working until I try to use an online application.
  ApportVersion: 2.6.1-0ubuntu4
  Architecture: amd64
   /dev/snd/controlC2:  luigi      2210 F.... pulseaudio
   /dev/snd/controlC0:  luigi      2210 F.... pulseaudio
   /dev/snd/controlC1:  luigi      2210 F.... pulseaudio
   country GB:
   	(2402 - 2482 @ 40), (N/A, 20)
   	(5170 - 5250 @ 40), (N/A, 20)
   	(5250 - 5330 @ 40), (N/A, 20), DFS
   	(5490 - 5710 @ 40), (N/A, 27), DFS
  DistroRelease: Ubuntu 12.10
  HibernationDevice: RESUME=UUID=2f1178cb-65b7-4f53-bddb-ddf4575dc2fe
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110921.2)
  MachineType: MEDIONPC MS-7707
  MarkForUpload: True
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=8b6a455e-f93f-4051-873f-0d755c268a52 ro quiet splash
  ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
   linux-restricted-modules-3.5.0-17-generic N/A
   linux-backports-modules-3.5.0-17-generic  N/A
   linux-firmware                            1.95
  Tags:  quantal running-unity
  Uname: Linux 3.5.0-17-generic x86_64
  UpgradeStatus: Upgraded to quantal on 2012-10-18 (1 days ago)
  UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
  dmi.bios.date: 04/01/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: E7707MLN.10E
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: MS-7707
  dmi.board.vendor: MEDIONPC
  dmi.board.version: 1.1
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: MEDIONPC
  dmi.chassis.version: 1.1
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE7707MLN.10E:bd04/01/2011:svnMEDIONPC:pnMS-7707:pvr1.1:rvnMEDIONPC:rnMS-7707:rvr1.1:cvnMEDIONPC:ct3:cvr1.1:
  dmi.product.name: MS-7707
  dmi.product.version: 1.1
  dmi.sys.vendor: MEDIONPC

To manage notifications about this bug go to: