← Back to team overview

kernel-packages team mailing list archive

[Bug 1312358] Re: 14e4:4331 [MacBookPro10, 2] wifi intermittent Ubuntu 14.04


I have the same problem as the reporting guy but in my case it's an HP laptop with Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01) wireless adapter. 
The problem is noticed when I donwnload big files from the internet, the connection is cut although it appears connected in the network panel. Executing 

sudo service network-manager restart

connects again and I can resume my download but it's very annoing doing
it every 5 minutes. I've tried the fix in this post but I get this

$ sudo iwconfig wlan0 power on
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  14e4:4331 [MacBookPro10,2] wifi intermittent Ubuntu 14.04

Status in “linux” package in Ubuntu:

Bug description:
  Problem: wifi is intermittent on my Macbook Pro and the logfile shows it's disconnecting
  Hardware System: Macbook Pro Retina 13" version 10,2 early 2013
  wifi firmware installed was default in Ubuntu 14.04 (mac 64bit OS) and synaptic shows the bcmwl-kernel-source to be installed. I get intermittent disconnections from the wifi which is set to g-only. Other wifi router settings have not been any better. Changing the wifi installation from the default of Ubuntu 14.04 have not improved things. I tried the firmware-b43-installer with similar results as above.

  iwconfig wlan0 | grep 'Power Management'
  Power Management:off

  WORKAROUND: Turn WiFi Power Management on.

  ApportVersion: 2.14.1-0ubuntu3
  Architecture: amd64
   /dev/snd/controlC0:  viking     2055 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=9a76124f-99fb-4ba8-8c94-f09d985809e9
  InstallationDate: Installed on 2014-04-24 (0 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64+mac (20140417)
  MachineType: Apple Inc. MacBookPro10,2
  NonfreeKernelModules: wl
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: \boot\vmlinuz-3.13.0-24-generic ro root=UUID=b6a171a9-799e-44f1-ab31-7d0940a39646 initrd=boot\initrd.img-3.13.0-24-generic
  ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
   linux-restricted-modules-3.13.0-24-generic N/A
   linux-backports-modules-3.13.0-24-generic  N/A
   linux-firmware                             1.127
  Tags:  trusty
  Uname: Linux 3.13.0-24-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 11/16/2012
  dmi.bios.vendor: Apple Inc.
  dmi.bios.version: MBP102.88Z.0106.B03.1211161133
  dmi.board.asset.tag: Base Board Asset Tag#
  dmi.board.name: Mac-AFD8A9D944EA4843
  dmi.board.vendor: Apple Inc.
  dmi.board.version: MacBookPro10,2
  dmi.chassis.type: 10
  dmi.chassis.vendor: Apple Inc.
  dmi.chassis.version: Mac-AFD8A9D944EA4843
  dmi.modalias: dmi:bvnAppleInc.:bvrMBP102.88Z.0106.B03.1211161133:bd11/16/2012:svnAppleInc.:pnMacBookPro10,2:pvr1.0:rvnAppleInc.:rnMac-AFD8A9D944EA4843:rvrMacBookPro10,2:cvnAppleInc.:ct10:cvrMac-AFD8A9D944EA4843:
  dmi.product.name: MacBookPro10,2
  dmi.product.version: 1.0
  dmi.sys.vendor: Apple Inc.

To manage notifications about this bug go to: