← Back to team overview

kernel-packages team mailing list archive

[Bug 1375995] Re: [HP Compaq dc7800 Small Form Factor PC] suspend/resume failure


@Matt Taylor
I have not filed an upstream bug for this. Until now I was not sure if I am the only one having this bug, so this information is helpful for me at least. As you can see in the activity log, I followed the procedure suggested in the Ubuntu Wiki, however, this did not result in more information. I also tried to remove as many kernel modules as possible, but I was still not able to resume. I even connected a serial console to my PC to see if some information is printed while supending/resuming, but the console is switched off before the freeze. Maybe there is more debug instrumentation in the kernel which could be activated or we have to modify the kernel with printk statements or use kgdb to find the place where it is freezing or the difference between the states after hibernation and power-up.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [HP Compaq dc7800 Small Form Factor PC] suspend/resume failure

Status in “linux” package in Ubuntu:

Bug description:
  Suspend to RAM fails on HP Compaq dc7800p, the PC will not wake up
  again. It only works if I suspend to disk before, then I can suspend
  to RAM afterwards (as many time as needed) until the PC is rebooted

  ProblemType: KernelOops
  DistroRelease: Ubuntu 14.10
  Package: linux-image-3.16.0-18-generic 3.16.0-18.25
  ProcVersionSignature: Ubuntu 3.16.0-18.25-generic 3.16.3
  Uname: Linux 3.16.0-18-generic x86_64
  Annotation: This occured during a previous suspend and prevented it from resuming properly.
  ApportVersion: 2.14.7-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC0:  urs        1849 F.... lxpanel
  CRDA: Error: [Errno 2] No such file or directory: 'iw'
  Date: Tue Sep 30 20:44:46 2014
  DuplicateSignature: suspend/resume:Hewlett-Packard HP Compaq dc7800p Small Form Factor:786F1 v01.32
  ExecutablePath: /usr/share/apport/apportcheckresume
  Failure: suspend/resume
  HibernationDevice: RESUME=UUID=c338e9df-bc69-4692-b108-88cfd64982a7
  InstallationDate: Installed on 2014-09-28 (2 days ago)
  InstallationMedia: Lubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140923)
  InterpreterPath: /usr/bin/python3.4
   eth0      no wireless extensions.
   lo        no wireless extensions.
  MachineType: Hewlett-Packard HP Compaq dc7800p Small Form Factor
  ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-18-generic root=UUID=6475de33-f0cf-4e4a-b155-bac5d4c61b27 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.16.0-18-generic N/A
   linux-backports-modules-3.16.0-18-generic  N/A
   linux-firmware                             1.134
  SourcePackage: linux
  Title: [Hewlett-Packard HP Compaq dc7800p Small Form Factor] suspend/resume failure
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/21/2011
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: 786F1 v01.32
  dmi.board.asset.tag: CZC81885DS
  dmi.board.name: 0AA8h
  dmi.board.vendor: Hewlett-Packard
  dmi.chassis.asset.tag: CZC81885DS
  dmi.chassis.type: 4
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: dmi:bvnHewlett-Packard:bvr786F1v01.32:bd07/21/2011:svnHewlett-Packard:pnHPCompaqdc7800pSmallFormFactor:pvr:rvnHewlett-Packard:rn0AA8h:rvr:cvnHewlett-Packard:ct4:cvr:
  dmi.product.name: HP Compaq dc7800p Small Form Factor
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: