← Back to team overview

kernel-packages team mailing list archive

[Bug 1396213] Re: LVM VG is not activated during system boot


I can't run apport-collect because Lynx doesn't send HTTP referrer to
Launchpad, and I don't wish to go through the ordeal of finding out how
to change this behaviour.

Furthermore, I'm not sure what logs would be collected. I can provide
logs you need manually, if you ask for them.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  LVM VG is not activated during system boot

Status in “linux” package in Ubuntu:

Bug description:
  Hi all,

  I open this report based on the linked conversation I had on the linux-lvm mailing list, and the Ask Ubuntu question I posted regarding this case.

  I have 2 VGs on my system, and for some reason, only one of them gets
  activated during the initrd boot sequence, which doesn't have my root
  LV, so my boot sequence halts with an initrd prompt.

  When I get to the initrd BusyBox prompt, I can see my LVs are inactive
  with "lvm lvscan" – then, "lvm vgchange -ay" brings them online. The
  boot sequence continues as I exit the BusyBox prompt. The expected
  behaviour would be that both VGs should activate automatically.

  On LVM mailing list, I've been advised it may be a problem with Ubuntu
  initrd scripts, hence I report this problem here. (I'm not sure if I'm
  reporting it to the correct place by assigning it to "linux", but I
  didn't find a package directly related to the initrd only, so I
  assumed initrd scripts are maintained by the kernel team. If you think
  it's an error, and know the correct package, please reassign!) Our
  suspicion is, initrd prematurely issues "vgchange -ay" before all the
  PVs come online. This makes sense.

  I already tried to set the "rootdelay" kernel parameter to make initrd
  wait longer for the boot LV to come up, but it didn't work. Note
  however, it worked with previous kernel versions.

  The problem came up when I upgraded to Utopic, and got kernel
  vmlinuz-3.16.0-23-generic. When I boot with the old kernel from Trusty
  (vmlinuz-3.13.0-37-generic), it works fine.

To manage notifications about this bug go to: