← Back to team overview

kernel-packages team mailing list archive

[Bug 1396291] UdevLog.txt


apport information

** Attachment added: "UdevLog.txt"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Maximum CPU frequency incorrect and there is no CPU scaling

Status in “linux” package in Ubuntu:

Bug description:
  I have an Acer Aspire 5720 and it is set up to dual boot Vista and
  ubuntu 14.04 LTS. From new the laptop came with an Intel T7300 2.00
  Ghz CPU and 1 GB DDR2 RAM. A few weeks ago I upgraded to 4 GB RAM,
  which works perfectly, and a few days ago I upgraded to an Intel T9300
  2.5 Ghz CPU.

  The BIOS (up to date), Vista and ubuntu all recognise the CPU
  correctly as:

  "Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50 GHz".

  Vista allows the CPU to run correctly at up to 2.5 Ghz and will step
  the CPU speed lower when not needed, depending on which power settings
  are chosen.

  The problem is that ubuntu will only allow the CPU to run at a fixed
  frequency of 2.4 Ghz, which is incorrect as it's a 2.5Ghz CPU, and
  there is no stepping to lower the CPU frequency when max frequency is
  not needed.

  "cpupower frequency-info" in a terminal returns:

  analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 2.40 GHz - 2.40 GHz
  available frequency steps: 2.40 GHz, 2.40 GHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 2.40 GHz and 2.40 GHz.
  The governor "ondemand" may decide which speed to use
  within this range.
  current CPU frequency is 2.40 GHz.
  cpufreq stats: 2.40 GHz:10.47%, 2.40 GHz:89.53% (12799)
  boost state support:
  Supported: yes
  Active: yes 

  I have tried using ondemand, performance and powersave - nothing makes
  any difference. I have also installed CPU Frequency Scaling Indicator
  (which shows only 2.4 Ghz and 2.4 Ghz (turbo mode) as available
  frequencies) and I have also tried TLP but nothing makes any

  According to this website:


  the T9300 CPU should have the following frequency steps:

  2.50 GHz, 2.00 GHz, 1.60 GHz, 1.20 GHz and 800 MHz.

  I have spent days trawling the internet for a solution but to no avail.  Hence filing this bug report in the hope a solution might be found.
  ApportVersion: 2.14.1-0ubuntu3.5
  Architecture: i386
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=0c4e3b98-0d40-4db3-9f4d-d1c53eb96355
  InstallationDate: Installed on 2014-04-23 (216 days ago)
  InstallationMedia: It
  MachineType: Acer Aspire 5720
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-40-generic root=UUID=9675b492-c55a-4c72-991b-263a27d74d5e ro quiet splash processor.ignore_ppc=1 vt.handoff=7
  ProcVersionSignature: Ubuntu 3.13.0-40.69-generic
   linux-restricted-modules-3.13.0-40-generic N/A
   linux-backports-modules-3.13.0-40-generic  N/A
   linux-firmware                             1.127.8
  Tags:  trusty
  Uname: Linux 3.13.0-40-generic i686
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 11/10/2008
  dmi.bios.vendor: Acer
  dmi.bios.version: V1.45
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: eMachine
  dmi.board.vendor: Acer
  dmi.board.version: V1.45
  dmi.chassis.type: 1
  dmi.chassis.vendor: Acer
  dmi.chassis.version: V1.45
  dmi.modalias: dmi:bvnAcer:bvrV1.45:bd11/10/2008:svnAcer:pnAspire5720:pvrV1.45:rvnAcer:rneMachine:rvrV1.45:cvnAcer:ct1:cvrV1.45:
  dmi.product.name: Aspire 5720
  dmi.product.version: V1.45
  dmi.sys.vendor: Acer

To manage notifications about this bug go to: