← Back to team overview

kernel-packages team mailing list archive

[Bug 1397032] Re: [Lenovo ThinkPad T540p] Intel Wireless Dual Band 7260AC fails to connect


Federico Sassi, could you please test the latest upstream kernel
available from the very top line at the top of the page (the release
names are irrelevant for testing, and please do not test the daily
folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will
allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested exactly shown as:

This can be done by clicking on the yellow circle with a black pencil
icon next to the word Tags located at the bottom of the bug description.

If the mainline kernel does not fix this bug, please add the following tags:

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your

** Tags removed: bios-outdated-2.16
** Tags added: latest-bios-2.16

** Changed in: linux (Ubuntu)
   Importance: Low => Medium

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Lenovo ThinkPad T540p] Intel Wireless Dual Band 7260AC fails to

Status in linux package in Ubuntu:

Bug description:
  I have a Lenovo Thinkpad T540p and the wireless connection isn't
  working correctly. It will list the available networks but when trying
  to connect it will keep asking for the password or when it connects
  the connection will last only few seconds and the packet loss on a
  ping will be very high.

  I've followed bug https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1354975 in order to find a solution but without luck. I've tried to turn off power management, install latest kernel ( linux-image-3.17.0-031700-generic ) and related updated firmware according to http://wireless.kernel.org/en/users/Drivers/iwlwifi . Tried also the updated firmware for the older kernel and with the older kernel.
  I've tried also Ubuntu 14.10 with same results. I've tried to move closer to the router but with no change at all.

  Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 83)
  	Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:c270]

  sudo lshw -C network
         description: Wireless interface
         product: Wireless 7260
         vendor: Intel Corporation
         physical id: 0
         bus info: pci@0000:04:00.0
         logical name: wlan0
         version: 83
         serial: e8:b1:fc:d2:e3:9e
         width: 64 bits
         clock: 33MHz
         capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
         configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-40-generic firmware= latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
         resources: irq:47 memory:e1400000-e1401fff

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-40-generic 3.13.0-40.69
  ProcVersionSignature: Ubuntu 3.13.0-40.69-generic
  Uname: Linux 3.13.0-40-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.5
  Architecture: amd64
   /dev/snd/controlC0:  fsassi     1930 F.... pulseaudio
   /dev/snd/controlC1:  fsassi     1930 F.... pulseaudio
  Date: Thu Nov 27 16:13:07 2014
  HibernationDevice: RESUME=UUID=650269f1-902f-4143-8cd4-27d1631b5d05
  InstallationDate: Installed on 2014-11-26 (0 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: LENOVO 20BECTO1WW
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-40-generic.efi.signed root=UUID=00883037-516d-4066-9e6b-581d1c2a4b7d ro quiet splash vt.handoff=7
   Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
   No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.13.0-40-generic N/A
   linux-backports-modules-3.13.0-40-generic  N/A
   linux-firmware                             1.127.8
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/22/2014
  dmi.bios.vendor: LENOVO
  dmi.bios.version: GMET67WW (2.15 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 20BECTO1WW
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0E50512 STD
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvrGMET67WW(2.15):bd09/22/2014:svnLENOVO:pn20BECTO1WW:pvrThinkPadT540p:rvnLENOVO:rn20BECTO1WW:rvrSDK0E50512STD:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 20BECTO1WW
  dmi.product.version: ThinkPad T540p
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: