← Back to team overview

kernel-packages team mailing list archive

[Bug 1397277] Re: Kernel dead after suspend/resume at i915


olegon.ru, thank you for reporting this and helping make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1397277

** Package changed: xserver-xorg-video-intel (Ubuntu) => linux (Ubuntu)

** Changed in: linux (Ubuntu)
   Importance: Undecided => Low

** Changed in: linux (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Kernel dead after suspend/resume at i915

Status in linux package in Ubuntu:

Bug description:
  HP ProBook 4740s, new installation of Ubuntu

  lsb_release -rd
  Description:	Ubuntu 14.10
  Release:	14.10

  Linux HP 3.16.0-25-generic #33-Ubuntu SMP Tue Nov 4 12:06:54 UTC 2014
  x86_64 x86_64 x86_64 GNU/Linux

    Installed: 2:2.99.914-1~exp1ubuntu4.1
    Candidate: 2:2.99.914-1~exp1ubuntu4.1

  lshw -c video
         description: VGA compatible controller
         product: 2nd Generation Core Processor Family Integrated Graphics Controller
         vendor: Intel Corporation
         physical id: 2
         bus info: pci@0000:00:02.0
         version: 09
         width: 64 bits
         clock: 33MHz
         capabilities: msi pm vga_controller bus_master cap_list rom
         configuration: driver=i915 latency=0
         resources: irq:48 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:3000(size=64)

  Suspend by menu at right upper corner. Waits... Wake up by button. Wallpaper and logon screen is appeared, periodically I can login and begin work, but not more than 5 seconds and system completely freezed. I can stay at login screen without keypress and its freezed too after some seconds.
  No mouse, keyboard, led or ssh activity is allowed. Kernel dead.
  Using fglrx or fglrx-updates it's no problem with suspend and resume, while using discrete card (not workaround for me). 

  I disabled Radeon card (in BIOS) and using i915. All fglrx and fglrx-
  updates is completely removed, xorg-radeon too.

  kernel option i915.modeset=0 resumed without hangs (but with black
  screen), and nomodeset too.

  tried to create xorg.conf with uxa

  Section "ServerLayout"
      Identifier "layout"
      Screen 0 "screen" 0 0

  Section "Device"
      Identifier "intel"
      Driver "intel"
      Option "AccelMethod" "uxa"
      BusID "PCI:0@0:2:0"

  Section "Monitor"
      Identifier "monitor"
      Option "VendorName" "HP"
      Option "ModelName" "HP Monitor"
      Option "DPMS" "true"

  Section "Screen"
      Identifier "screen"
      Device "intel"
      Monitor "monitor"
      DefaultDepth 24
      SubSection "Display"
          Viewport   0 0
          Depth     24

  but hangs too :(

  Hibernation works without any problem.

  Tried latest Linux Mint (booting with usb-stick) - hangs on
  suspend/resume too. Sometimes ago can suspend/resume at Windows 7, but
  I hate this OS.

  I suffered to resolve this problem last three days...

To manage notifications about this bug go to: