← Back to team overview

kernel-packages team mailing list archive

[Bug 1391657] Re: Unreliable connection with bcm43142 and bcmwl-driver on HP Stream Notebook 14-z010nz


Hello Christopher
Thank you for helping. modprobe lib80211 did not solve the problem by the way.

Right now, I'm testing the broadcom-sta-source package for vivid and it looks promising. Will do some more testing. If
this doesn't work either I will go back to bcmwl-kernel-source and
provide the information you asked for.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bcmwl in Ubuntu.

  Unreliable connection with bcm43142 and bcmwl-driver on HP Stream
  Notebook 14-z010nz

Status in bcmwl package in Ubuntu:

Bug description:
  With my Broadcom bcm43142 Wifi-Adapter I am getting random disconnects
  on relatively short intervals. The adapter seems to have problems with
  roaming and multiple APs. Sometimes the wifi connectivity stops being
  available alltogether. This is usually after a period of time. In this
  situation the wifi option doesn't show in networkmanager applet or as
  connection in network configuration. Sometimes the wifi is seemingly
  connected (wifi symbol in the status bar). But no website can be

  Attempts to solve the problem:
  -I tried compiling the STA-source from Broadcom. It didn't compile
  -I also tried the ndiswrapper solution. The device was recognised but network-manager crashed on every attempt to configure the wifi.
  -The network would run fine with an alternative usb-wifi-adapter with a Realtek chip in it. So it is most likely a problem related to this Broadcom device and the STA driver
  -The older version of this package does not support this model bcm43142.

  Since wifi is the only network connectivity available on this
  netbook/ultrabook, a solid driver installation would be much
  appreciated. Maybe something could be done about it despite the
  Broadcom STA driver's bad reputation.

  WORKAROUND: modprobe lib80211

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: bcmwl-kernel-source
  ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
  Uname: Linux 3.16.0-24-generic x86_64
  NonfreeKernelModules: wl fglrx
  ApportVersion: 2.14.7-0ubuntu8
  Architecture: amd64
  CurrentDesktop: GNOME
  Date: Tue Nov 11 21:23:24 2014
  InstallationDate: Installed on 2014-11-08 (2 days ago)
  InstallationMedia: Ubuntu-GNOME 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
  SourcePackage: bcmwl
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: