← Back to team overview

kernel-packages team mailing list archive

[Bug 1361670] Re: 14e4:43a0 [MacBookAir6, 2] NO wireless network


For future reference, kolasa has a repository that have the patches required to make the driver work on 3.17 (and 3.18).

Personally I used dpkg-deb to edit the official deb file and add his
patches in (specifically 0011 and 0012), got it installed and it's
working perfectly so far.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bcmwl in Ubuntu.

  14e4:43a0 [MacBookAir6,2] NO wireless network

Status in bcmwl package in Ubuntu:

Bug description:
  Im trying out new kernels to get monitor via thunderbolt and i noticed
  that the wireless stoped working for me. I have tried two 3.16.*
  kernels and the latest 3.17 rc2 with the same result.

  make: Entering directory `/usr/src/linux-headers-3.17.0-031700rc2-generic'
  CFG80211 API is prefered for this kernel version
  Using CFG80211 API
    LD      /var/lib/dkms/bcmwl/
    CC [M]  /var/lib/dkms/bcmwl/
    CC [M]  /var/lib/dkms/bcmwl/
  /var/lib/dkms/bcmwl/ In function ‘wl_alloc_linux_if’:
  /var/lib/dkms/bcmwl/ error: macro "alloc_netdev" requires 4 arguments, but only 3 given
    dev = alloc_netdev(sizeof(priv_link_t), intf_name, ether_setup);
  /var/lib/dkms/bcmwl/ error: ‘alloc_netdev’ undeclared (first use in this function)
    dev = alloc_netdev(sizeof(priv_link_t), intf_name, ether_setup);
  /var/lib/dkms/bcmwl/ note: each undeclared identifier is reported only once for each function it appears in
  make[1]: *** [/var/lib/dkms/bcmwl/] Error 1
  make: *** [_module_/var/lib/dkms/bcmwl/] Error 2
  make: Leaving directory `/usr/src/linux-headers-3.17.0-031700rc2-generic'

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-34-generic 3.13.0-34.60
  ProcVersionSignature: Ubuntu 3.13.0-34.60-generic
  Uname: Linux 3.13.0-34-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.14.1-0ubuntu3.3
  Architecture: amd64
   /dev/snd/controlC2:  kempe      5730 F.... pulseaudio
   /dev/snd/controlC0:  kempe      5730 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Tue Aug 26 15:39:04 2014
  HibernationDevice: RESUME=UUID=2152d16b-e1dd-4ea0-b930-939e5ab669b1
  InstallationDate: Installed on 2014-07-01 (55 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: Apple Inc. MacBookAir6,2
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-34-generic.efi.signed root=UUID=bd3d552c-0546-4c43-accc-ebd45b2f7eb7 ro pcie_aspm=force "acpi_osi=!Windows 2012" acpi=force acpi_enforce_resources=lax i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 i915.semaphores=1 intel_pstate=enable
   linux-restricted-modules-3.13.0-34-generic N/A
   linux-backports-modules-3.13.0-34-generic  N/A
   linux-firmware                             1.127.5
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 05/24/2014
  dmi.bios.vendor: Apple Inc.
  dmi.bios.version: MBA61.88Z.0099.B12.1405241030
  dmi.board.asset.tag: Base Board Asset Tag#
  dmi.board.name: Mac-7DF21CB3ED6977E5
  dmi.board.vendor: Apple Inc.
  dmi.board.version: MacBookAir6,2
  dmi.chassis.type: 10
  dmi.chassis.vendor: Apple Inc.
  dmi.chassis.version: Mac-7DF21CB3ED6977E5
  dmi.modalias: dmi:bvnAppleInc.:bvrMBA61.88Z.0099.B12.1405241030:bd05/24/2014:svnAppleInc.:pnMacBookAir6,2:pvr1.0:rvnAppleInc.:rnMac-7DF21CB3ED6977E5:rvrMacBookAir6,2:cvnAppleInc.:ct10:cvrMac-7DF21CB3ED6977E5:
  dmi.product.name: MacBookAir6,2
  dmi.product.version: 1.0
  dmi.sys.vendor: Apple Inc.

To manage notifications about this bug go to: