← Back to team overview

kernel-packages team mailing list archive

[Bug 467490] Re: nvidia drivers don't work due to -Q in obsolete /etc/modprobe.d/lrm-video


karmic has seen the end of its life and is no longer receiving any
updates. Marking the karmic task for this ticket as "Won't Fix".

** Changed in: nvidia-common (Ubuntu Karmic)
       Status: Triaged => Won't Fix

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to nvidia-common in Ubuntu.

  nvidia drivers don't work due to -Q in obsolete /etc/modprobe.d/lrm-

Status in nvidia-common package in Ubuntu:
  Fix Released
Status in nvidia-common source package in Lucid:
  Fix Released
Status in nvidia-common source package in Karmic:
  Won't Fix

Bug description:
  I am not sure what is going on here but I recently upgraded from 8.04
  to 9.10 and my nvidia drivers aren't working.  I couldn't add via the
  "hardware drivers" app.  It just didn't work.

  When I tried to add using apt-get it still didn't work.  I tried
  inserting the nvidia module using modprobe and I got and error stating
  that "Q" was an invalid option.  After some scouring of the web I
  found a reference suggesting that I comment out lines in
  /etc/modprobe.d/lrm-video so I tried commenting out a line in this
  file.  What do you know it worked.  Here is a copy of that file;

  # Make nvidia/nvidia_legacy and fglrx use /sbin/lrm-video to load
  install fglrx /sbin/lrm-video fglrx $CMDLINE_OPTS
  #install nvidia /sbin/lrm-video nvidia $CMDLINE_OPTS
  install nvidia_legacy /sbin/lrm-video nvidia_legacy $CMDLINE_OPTS
  install nvidia_new /sbin/lrm-video nvidia_new $CMDLINE_OPTS

  So, now I have a working nvidia driver.  However this seems to have broken my audio.  :(

  I have no idea what this file does or what I have done by commenting
  out this line other than getting the nvidia driver to finally load.

  I have no idea why commenting this out would cause my audio to fail?
  Any help would be appreciated.



  ProblemType: Bug
  Architecture: i386
  Date: Sat Oct 31 16:31:05 2009
  DistroRelease: Ubuntu 9.10
   Fatal server error:
   Server is already active for display 0
   	If this server is no longer running, remove /tmp/.X0-lock
   	and start again.
   Fatal server error:
   Server is already active for display 0
   	If this server is no longer running, remove /tmp/.X0-lock
   	and start again.
  MachineType: System manufacturer System Product Name
  NonfreeKernelModules: nvidia dm_raid45 xor usbhid usb_storage ati_agp r8169 mii agpgart
  Package: nvidia-glx-185 185.18.36-0ubuntu9
  ProcCmdLine: root=UUID=dc199ea7-e35b-4271-bd97-6b30d7aa06c3 ro quiet splash
   PATH=(custom, user)
  ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
   xserver-xorg 1:7.4+3ubuntu7
   libgl1-mesa-glx 7.6.0-1ubuntu4
   libdrm2 2.4.14-1ubuntu1
   xserver-xorg-video-intel 2:2.9.0-1ubuntu2
   xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
  SourcePackage: nvidia-graphics-drivers-180
  Uname: Linux 2.6.31-14-generic-pae i686
  XsessionErrors: (polkit-gnome-authentication-agent-1:3819): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
  dmi.bios.date: 10/22/2008
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: ASUS M2A-VM ACPI BIOS Revision 2201
  dmi.board.name: M2A-VM
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: 1.XX
  dmi.chassis.asset.tag: 123456789000
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2A-VMACPIBIOSRevision2201:bd10/22/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2A-VM:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer
  fglrx: Not loaded
   distro:             Ubuntu
   architecture:       i686kernel:             2.6.31-14-generic-pae

To manage notifications about this bug go to: