← Back to team overview

kernel-packages team mailing list archive

[Bug 1397383] Re: 14e4:4359 [Dell Latitude 5530] Broadcom BCM43228 WiFi interface not recognized with linux-generic-lts-utopic 3.16.0-25


Ok, after some new attempts I can file a report of what's going on.
I tried again with a live session on a daily ubuntu image. By issuing manually inside a shell the command

sudo apt-get install bcmwl-kernel-source

the wireless network is immediately recognised.
So I decided to try this same command on my installed 14.04.1 system with the 3.16.0-25 kernel, but the package is already installed,  and won't istall again.
Then I tried this:

sudo apt-get --reinstall install  bcmwl-kernel-source

after this the wireless network does NOT work. Instead, the command also broke my working network with 3.13.0-40 kernel!!!
Besides, the command

sudo modprobe wl

gives:  "no such module"

In an attempt to fix my wireless network within the 3.13 kernel I
reinstalled the bcmwl package again. The command was issued under the
old kernel this time, and this is the result:

Loading new bcmwl- DKMS files...
Building for 3.13.0-40-generic and 3.16.0-25-generic
Building for architecture x86_64
Building initial module for 3.13.0-40-generic

Running module version sanity check.
 - Original module
    - No original module exists within this kernel
     - Installation
        - Installing to /lib/modules/3.13.0-40-generic/updates/dkms/


        DKMS: install completed.
        Building initial module for 3.16.0-25-generic
        Error! Bad return status for module build on kernel:
3.16.0-25-generic (x86_64)
Consult /var/lib/dkms/bcmwl/ for more
update-initramfs: deferring update (trigger activated)
Elaborazione dei trigger per initramfs-tools (0.103ubuntu4.2)...

I would stress the attention on this part:

"........Error! Bad return status for module build on kernel:...."

The wireless network works again under 3.13, but apparently, for some reason, the module is NOT built for the new kernel. So  it seems that some compilation error is present.
I attached the make.log file.

** Attachment added: "make.log"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bcmwl in Ubuntu.

  14e4:4359 [Dell Latitude 5530] Broadcom BCM43228 WiFi interface not
  recognized with linux-generic-lts-utopic 3.16.0-25

Status in bcmwl package in Ubuntu:

Bug description:
  I have a Dell latitude 5530 laptop with the Broadcom BCM43228 wireless card, and I currently run Kubuntu 14.04.1 LTS. It works ok with the 3.13.0-40 original linux kernel, but after installing the linux-generic-lts-utopic kernel (version 3.16-25) the wireless interface does not appear any more. The kubuntu applet for network connections does not allow to switch the wireless network on. Booting back with 3.13 kernel can fix the issue, so it's not a hardware problem. The following commands do not give any output concerning the wireless interface wlan0 or the BCM43228:
  dmesg | grep 'BCM'

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-generic-lts-utopic
  ProcVersionSignature: Ubuntu 3.13.0-40.69-generic
  Uname: Linux 3.13.0-40-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.14.1-0ubuntu3.5
  Architecture: amd64
  CurrentDesktop: KDE
  Date: Fri Nov 28 17:35:37 2014
  InstallationDate: Installed on 2013-04-25 (581 days ago)
  InstallationMedia: Kubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
  SourcePackage: linux-meta-lts-utopic
  UpgradeStatus: Upgraded to trusty on 2014-04-18 (224 days ago)

To manage notifications about this bug go to: