← Back to team overview

kernel-packages team mailing list archive

[Bug 913091] Re: suspend when closing laptop-lid dosen't work


Malin Bruland, could you please test the latest upstream kernel
available from the very top line at the top of the page (the release
names are irrelevant for testing, and please do not test the daily
folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will
allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:

where VERSION-NUMBER is the version number of the kernel you tested exactly shown as:

This can be done by clicking on the yellow circle with a black pencil
icon next to the word Tags located at the bottom of the bug description.

If the mainline kernel does not fix this bug, please add the following tags:

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your

** Changed in: linux (Ubuntu)
   Importance: Low => Medium

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  suspend when closing laptop-lid dosen't work

Status in linux package in Ubuntu:

Bug description:
  Description:	Ubuntu 11.10
  Release:	11.10 

    Installed: 1.4.1-8ubuntu1
    Candidate: 1.4.1-8ubuntu1
    Version table:
   *** 1.4.1-8ubuntu1 0
          500 http://no.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
          100 /var/lib/dpkg/status
  I expect the laptop to suspend when the laptop-lid is closed and to wake up again when I open the laptop-lid and into the suspended session

  When I close the laptoplid, my laptop dosen't suspend. If I run the command pm-suspend it suspends, but then I can't power on my laptop without either pulling out my battery, or pressing the power-button for several seconds, release it and then push again to boot. The suspended session is not stored, and the computer boots as a cold/fresh boot, without wakeup my last suspended session.

  Things I have tried: suspend works with the 2.6.38-kernel series and earlier, but I can't get suspend to work with 2.6.39 and newer. I alså tried to upgrade to both kernel 3.1 and 3.2, but no luck

  6) Laptopmodel: Clevo w761tun  / Zepto M15a

  ProblemType: Bug
  DistroRelease: Ubuntu 11.10
  Package: pm-utils 1.4.1-8ubuntu1
  ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
  Uname: Linux 3.0.0-14-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 1.23-0ubuntu4
  Architecture: amd64
  Date: Sat Jan  7 12:26:58 2012
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  PackageArchitecture: all
  SourcePackage: pm-utils
  UpgradeStatus: No upgrade log present (probably fresh install)

  This also affects ubuntu 12.04 lts alpha2: (entered manually)

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04 LTS alpha2
  Package : pm-utils 1.4.1-9
  ProcVersionSignature: Ubuntu 3.2.0-15.24-generic
  Uname: 3.2.0-15-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 1.91-0ubuntu1
  Architecture : amd64
  InstallationMedia : Ubuntu 12.04 "Precise Pangolin" -Release amd64 (20120202)
  PackageArchitecture :all
  SourcePackage : pm-utils
  UpgradeStatus: No upgrade log present (probably fresh install)
  ApportVersion: 2.14.1-0ubuntu3.6
  Architecture: amd64
   /dev/snd/controlC0:  malin      3227 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=aa05d848-71ef-4351-9944-bb7994a5c2f7
  InstallationDate: Installed on 2014-05-07 (211 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: Zepto M15a
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=c814c9ea-8492-48e3-b5e1-839076dcefc5 ro acpi_sleep=nonvs quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap
  ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
   linux-restricted-modules-3.13.0-24-generic N/A
   linux-backports-modules-3.13.0-24-generic  N/A
   linux-firmware                             1.127.10
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  Tags:  trusty
  Uname: Linux 3.13.0-24-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom davfs2 dip libvirtd lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 06/30/2009
  dmi.bios.vendor: Phoenix Technologies LTD
  dmi.bios.version: 1.02.23ZC
  dmi.board.asset.tag: Tag 12345
  dmi.board.name: M15a
  dmi.board.vendor: Zepto
  dmi.board.version: M15a
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 1
  dmi.chassis.vendor: No Enclosure
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr1.02.23ZC:bd06/30/2009:svnZepto:pnM15a:pvrM15a:rvnZepto:rnM15a:rvrM15a:cvnNoEnclosure:ct1:cvrN/A:
  dmi.product.name: M15a
  dmi.product.version: M15a
  dmi.sys.vendor: Zepto

To manage notifications about this bug go to: