← Back to team overview

kernel-packages team mailing list archive

[Bug 1388430] Re: nvidia-settings closes when pressing 'Apply' button, but changes aren't applied


This is probably the same issue as bug 1273652.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to nvidia-settings in Ubuntu.

  nvidia-settings closes when pressing 'Apply' button, but changes
  aren't applied

Status in nvidia-settings package in Ubuntu:

Bug description:
  1. I recently did a fresh install of Ubuntu 14.04 (64 bits) on my machine, which has an Nvidia GeForce 6200 graphics card. When I try to change the screen resolution, changes are not being applied and nvidia-settings is closing when I press the 'Apply' button.
  2. I run nvidia-settings in a terminal, and I got the following error message after pressing the 'Apply' button (see the attached file):

  The program 'nvidia-settings' received an X Window System error.
  This probably reflects a bug in the program.
  The error was 'BadValue (integer parameter out of range for operation)'.
    (Details: serial 528 error_code 2 request_code 158 minor_code 25)
    (Note to programmers: normally, X errors are reported asynchronously;
     that is, you will receive the error a while after causing it.
     To debug your program, run it with the --sync command line
     option to change this behavior. You can then get a meaningful
     backtrace from your debugger if you break on the gdk_x_error() function.)

  3. This seems to be a duplicate of Bug #1273652.
  4. I contacted Nvidia custom care support, and they suggested me to try the latest driver version (304.123). Unfortunately, when I checked "nvidia-graphics-drivers-304" at Launchpad, I found it's only available for Utopic, Precise, and Vivid (indeed, it doesn't appear in my Additional Drivers wizard).

  If you help me to install version 304.123 on my system, I'll give
  Nvidia Linux maintainers all the feedback they are requesting from me,
  and I'll be in a better condition to colaborate with you to solve this
  issue (installation instructions provided by Nvidia website are hard
  for me to follow). Feel free to e-mail me if you think I can help in
  any way.

  5. You can find additional information about similar issues in the
  following links:


  6. System settings:

  OS version: Ubuntu 14.04 LTS (64 bits)
  Nvidia driver version: 304.117
  nvidia-settings version: 331.20-0ubuntu8

  P.S: apparently, this is not the first time a bug like this affects
  nvidia-settings on Ubuntu. If you read the comments at the second and
  third links in point 5 (above), there is people who solved the issue
  after they installed an nvidia-settings package which version number
  matches the driver one (or vice-versa).

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: nvidia-settings 331.20-0ubuntu8
  ProcVersionSignature: Ubuntu 3.13.0-39.66-generic
  Uname: Linux 3.13.0-39-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.14.1-0ubuntu3.5
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sat Nov  1 14:33:26 2014
  InstallationDate: Installed on 2014-11-01 (0 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
   PATH=(custom, no user)
  SourcePackage: nvidia-settings
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: