← Back to team overview

kicad-developers team mailing list archive

Re: CMake on Linux


--- In kicad-devel@xxxxxxxxxxxxxxx, "Mateusz Skowroński" <skowri@...>

> cmake -DCMAKE_BUILD_TYPE=Debug -DwxWidgets_USE_DEBUG=ON \
-DwxWidgets_CONFIG_EXECUTABLE=/usr/local/bin/wx-config ../../

> > That did it...it's making now! I also had a
> > /usr/local/wx/bin/wx-config but not first in the PATH.
> >
> You're welcome.
> Happy hacking.
> Mateusz
works fine (make, make install) in ../../Build/Debug, kicad runs fine,

but not in the Release Dir:
cmake -DCMAKE_BUILD_TYPE=Release \
-DwxWidgets_CONFIG_EXECUTABLE=/usr/local/bin/wx-config ../../
make, make install seems happy but when I run:

/home/fwb/homepage# kicad
Fatal Error: Mismatch between the program and library build versions
The library used 2.8 (debug,ANSI,compiler with C++ ABI 1002,wx
containers,compatible with 2.6),
and your program used 2.8 (no debug,ANSI,compiler with C++ ABI 1002,wx
containers,compatible with 2.6).
Abort (core dumped) 

How best to cleanup? which libraries? I tried to remake wxWidgets
without debug as well...make clean doesn't.