kicad-developers team mailing list archive
Mailing list archive
Re: Potential issues with oaa_ lib
> 4) I would also add R-M12.5 and R-I500. Physically those would be the
> standard 0.5-0.6W (R5 footprint in the standard library). I know R-M10
> is adequate for those, but sometimes 12.5 is preferable.
>> Good idea - I've added them.
> 5) The D-SUB connectors:
> Excellent work (and this is an understatement).
> One little issue; The side pads normally accommodate some sort of
> mounting mechanism. I've worked with several DB9's, and they all needed
> a hole of 3.2mm. I know the pad is 3.2mm, but when generating drill
> files, the hole size will be the size of the hole, not that of the
> drill. That's not a big problem when drilling manually, but when using a
> CNC, especially with auto-tool-change, it can give the engineer quite a
> few headaches.
> The recommended hole size varies between manufacturers, but all
> datasheets that I've consulted "stated" "compatibility" with 3.2mm
> holes. (Amphenol: 3.2+- 0.126; Harting: 3.1+-0.1, etc).
>> You're right - I don't know why I chose those values,
>> but I've now increased the hole to 3.2mm and the pad to
>> 6.5mm, which is larger than MAX(M3 screw head, M3 nut).
This is from an email I wrote on the list:
> I've made them 6.8 (6.4 nut diameter + 0.2 tolerance from the hole (M3
> in 3.2mm hole) + 0.2 safety margin).
Referring exactly to the pad size for an M3 nut without washer.
The general rule I use is
Max component size + Screw in hole tolerance + Other tolerance (like
washer to screw) + some random value (0.2 mm :) )
The following would amass to (M3 screw in 3.2mm hole)
Screw only: 6.4mm
The last one doesn't exactly follow the formula above; if it did, the
full-body-condom--safe pad size for an M3 washer would be 7.8mm (a 3.4mm
ID washer fitting over an M3 thread add the 0.4). I don't think anyone
will need as much torque to justify a washer, so 6.8mm should be fine.
> I would also rename the library to dsub, or conn_dsub. Then the Molex
> Micro-Fit library I'm dying to work on would be conn_microfit. Anyway,
> semantics :) .
>> Yes, you're right - there are _way_ too many
>> connectors out there to put them all in one big lib :-)
>> I've renamed it to conn_db (or maybe it should be conn_db_dsub ?).
I think conn_db_dsub is more explicit. Just my two eurocents :)
> Other than these few glitches, I see no reason why it shouldn't be
> merged with the standard kicad libraries. Your branch on kicad-newlib
> would stay active and in developed, and ocasionally, it would be merged
> with the standard libs. This way users can use the library, and
> development would stay separate from the main libs. What do you say?
>> Well, with almost 1000 components, there's bound to be
>> some minor problems, like the ones you've found, so I think
>> that some more double-checking first would be a good idea :-)
LOL. That's exactly what I do in my free time.
I don't know if I had a chance to point this one out yet, but the SOD523
package has overlapping pads (still there in revision 3).
>> The pad size and position on the Al SMD Caps (C-AEC-*)
>> is pure guesswork, as I couldn't find any land pattern
>> info :-(, so they definitely needs double-checking ...
I'll try to see if I can get this info from suppliers.
> I've commited the above corrections as revision 2.
I've already pulled revision 3 :) .