← Back to team overview

kicad-developers team mailing list archive

Re: exploiting human readability

 

> (part REFDES is PLID
>   (at X Y)
>   (rot 0)  # make this optional, defaulting to zero
> )
>   


Schematic component instantiation:
---------------------------------

I don't know that "part" is best, and there may be a better name.

But what I see from this, unless there are holes in the concept, is that
there need be *NO location information* in what we have been calling the
component, nor any rotation information.

That can be introduced in the part C++ PART class for the very first
time.  The graphics primitives in the component have their coordinates,
but those coordinates are relative to the component's origin, not any
thing beyond that.


The component is located and rotated [and mirrored] when it is
instantiated within a part.


class PART
{
    COMPONENT* component        // points into the parts list

    POINT pos;

    wxString  reference;

    int angle;
}


Something like that.  Maybe also mirroring support at the PART level. 
The get bounding box function delegates to the COMPONENT, and offsets
and rotates the result of that box to the region on screen.

Are part and component properly named?

Dick






Follow ups

References