← Back to team overview

kicad-developers team mailing list archive

About the NextColor function

 

I'm not too happy to discard the convenience of C++ operator overloading
only to fix a swig warning...

Other than that, if we have to need a named function at least we should
have it in functional fashion like col = NextColor(col) or a better name
like Advance(col); actually Advance(&col), since we decided not to use
nonconst references... in my private branch I am using ADTs even for
LAYER_NUM and LAYER_MSK (implemented as enum but ready for 'upgrade');
it would be a real mess to not being able to use operators ++, & and
| (for example).

Do we really want to make without operator overloading? Being from
a LISP background I have no issue with that (since there are no
operators and everything is prefix, anyway) but in C++ this is... ugly.

I'd like to discuss this (since I have a lot of ++, & and | done on
layers, now...)

-- 
Lorenzo Marcantonio
Logos Srl


Follow ups